Programming Eth Mainboard

I have all the updated drivers and all the cables are connected to my computer. So i am trying to run a test program that looks like this:

namespace GadgeteerApp2
public partial class Program
// This method is run when the mainboard is powered up or reset.
void ProgramStarted()
OutputPort LED;
LED = new OutputPort((Cpu.Pin)75, true);
Debug.Print(“Program Started”);

However i am getting an error that says: Device not found or cannot be opened - USB:Gadgeteer.

How can i fix this and run the program?

@ UofLTCI - not sure, but with Gadgeteer you shouldn’t have the thread.sleep

If you are using this board:

Then you have to install the SDK from the link below, under SDKs and drivers

Also use code tags to let formatting feature of the forum make your code look pretty.

1 Like

Yea i already have all the SDK’s and drivers installed and im using the NETMF 4.2 framework. But it still gives me the same error.

Then you have wrong board selected in the Project properties window.
It should be USB:MountaineerEth

1 Like

I don’t think that is the problem. I went and replaced the built in mainboard with the MountaineerEth board but i still get the same error. Unless there is another place that i need to change it at.

@ UofLTCI - on the project properties on the .net micro tab what is displayed under I think deployment - on phone so guessing the names…

1 Like

the deployment has Transport: USB
and the device shows
I clicked on the drop down box but was the only option. However i typed in “MountaineerEth” but it didn’t do anything. Is the device maybe not installed properly?

@ UofLTCI - you can’t type in there, if the board is plugged in and happy it will display mounteneer…

@ UofLTCI - Can you see the board with MFDeploy?

1 Like

Not at all… :confused:

@ UofLTCI - tried a different USB cable? Powered hub?

Yea i just tried a different USB cable and the power light comes on with either so it isn’t the hub. I’ve tried it in all 4 of the USB ports on my computer as well.

I just tried a second mainboard but there is no change at all.

Have you reflashed it or is it factory original?

factory original, because i just opened its packaging right before i hooked it up.

if you have all the correct drivers and sdk’s installed then i would try updating the firmware…

1 Like

Did you install the USB driver for the board as explained in the getting started guide?

1 Like

I found a way to reset and reinstall the driver and i also checked the firmware which I had installed but never got implemented apparently so i uninstalled the firmware and reinstalled it and It is fixed and i can chose the mainboard as device under properties. However the code now returns the error that there is something wrong with your hardware. However i think that the issue with that is that the way i initialize the outputport is incorrect. I might switch from gadgeteer to plain vanilla. Do you have a preference either way, all im using are Digital and/or Analog I/O.

Good news, post up the code that is causing the issue.
I tend to mix them together, so i guess use which one feels more comfortable.