Main Site Documentation

Problems with MFDeploy's Create Application deployment


#1

Hi all!

I’m working on an application that is going to have ifu capabilities. However, i’m having troubles getting MFDeploy to grab my managed .hex from the board (G120HDR). When i choose a file name for the .hex and a key-name and click OK, the status bar fills up with green to almost complete but then it seem to get stuck and nothing happens.

It does connect to the device, and i can see that the application i working as intended (for now its only job is to print “hello”), so that doesn’t seem to be the issue.

I’ve also tried TeraTerm with XMODEM transfer but havent succeeded with that either.

I have updated to the latest firmware but that didn’t solve the problem.

Grateful for any suggestions

Ps. I should perhaps add that I’m pretty much a noob when it comes to micro framework and hardware in general.


#2

Thank you for the quick response. You were right in that i was using MFDeploy 4.3 and my firmware is 4.2.x.x. So i downloaded the Micro Framework 4.2 sdk and tried to do create the application .hex but got the same problem, it seemed to get stuck in the process.

However, as I was writing this message it suddenly finished successfully! How long does this process normally take. It was running for at least 5 minutes now before it finished.

Anyhow, thank you so much for the response. I’m looking forward to bother y’all with further questions in the future :slight_smile:


#3

Btw, how do I mark your answer as the solution to my problem?


#4

Ok, so now i have a problem with this again. When I switched to mfdeploy for 4.2, it started working,allthough the Create Application Deployment took like 5 minutes, even for a super small application (litterally just Debug.Print(“Hello”) every 5s).

Now I no longer cant get it to work though. I can extract a hex from mfdeploy, but when i try to run it in a SystemUpdate.Load, it fails with exception: An unhandled exception of type ‘System.ArgumentException’ occurred in GHI.Premium.SystemUpdate.dll

And if i try to deploy it from mfdeploy it fails with the message Error: Signature check failed for update.sig

where update.hex is my application name.

Any ideas?


#5

I think latest FEZ Config tool supports application deployment. Does it work better for you?


#6

Nice tool. It now works to extract a hex and deploy it back to the device with the config tool. But i still cant do the SystemUpdate.Load with the same file, i get a System.ArgumentException with no further info.

Maybe i should take that question to some other thread though?


#7

Yes please start a new thread with details about your device and setup. Make sure you have the latest SDK.