Problems with G30 Debug Interface

Good Morning Guys.

I have a G30 based custom board, and I’m facing some problems to start my debug. I’m sure LDR0 pin is High on startup, but in my Device Manager my G30 is being recognized as “GHI Bootloader Interface”. So I connected my G30 Dev Board Rev 1.0 and it’s recognized as “GHI NETMF Interface”. When I boot my G30 Dev Board with LDR0 Button pressed in my device manager it’s shown as “GHI Bootloader Interface”, so I suspect it’s something related to LDR0 pin.

Attached you can see Device Manager with both boards Connected, and you can also see my LDR0 connection.

Thanks in advance for your support.

You just need to load the firmware you desire.

Hi Gus.

Thanks for your quick reply.

The problem I´m facing is the kind of device is being mounted in Device Manager. From Visual Studio I´m able to deploy and debug my firmware
in my G30 Dev Borad, because it´s enumerating and being recognized as “GHI NETMF Interface”. But, when I attach my G30 Custom Board,
it’s recognized as “GHI Bootloader Interface (COM6)”, so Visual Studio can’t deploy the firmware and show me a message that cant communicate with G30 processor…

Thanks in advance for your support.

@ malvarezdel - load our firmware I mean, not your application. Open the FEZ config program found in our SDK.

@ Gus - I have tried with Fez Config, and G30 is detected (COM6) but when I try to update firmware I get an error “Device is not connected or not responding” so I opened my Terminal software, sent v and received version number v2.0.1

Attached are some screen captures for your reference.

@ malvarezdel - to load manually, on terminal, send X and then send the firmware file using X modem 1k. Do not forget 1K.

1 Like

@ Gus - :clap: Thank you very much, I must say xmodem transfer was scary…, but now it works.

For production purposes I must ask you a couple of questions:

Is this the standard procedure, or in the future we will receive G30 chips with firmware pre-loaded?
Why did Fez Config was not able to update firmware in my G30?
What happens if xmodem 1K transfer is interrupted? my G30 will brick?

Thanks again for your support

@ malvarezdel - reach company may require a certain version and so we do not load a specific firmware. You can however social order the chips with the firmware pre loaded, with a minimum and possible surcharge. Let is know when you are ready for production please.

@ Gus - Sure, I´ll contact you when ready.

Thanks again.