Problems with Domino Driver Installation

I have had a FEZ Domino which has been working fine until recently. Not sure what I did wrong, but it is no longer recognised by my computer. I tried removing the Microsoft .NET Micro Framework, GHI NETMF v4.1 and .NET Gadgeteer Package, then re-installing the latest versions, but every time the board is plugged in, I get “Windows was unable to install your USBizi” and “Windows could not find driver software for your device”. When I look at the computer’s Device Manager, it is worth noting that the following can be seen when the Domino is plugged in: “USBizi” and “CDC VCOM” (not sure what the latter is?). My computer makes the usual beeps when plugged in with the USB cable and the same again when unplugged. The Domino also looks visually fine with its power light on. Today, in order to see if there was something wrong with the setup on my usual computer, I installed all the usual software onto a new laptop and tried connecting the Domino, but the same thing happened.

Could someone please advise on how to solve this problem?

Many thanks


Hi Ian,

USBizi showing up means that there’s some form of issue on the device not allowing the GHI debuggable device driver to load. I suggest you hold LDR down and boot into bootloader mode, erase all, and reapply the firmware. Then after a reboot you should either see the GHI debuggable device or the same as you did - if the same, you may well have a hardware type issue, otherwise you’re good to go again. Hope this helps!

Hi Brett,

I tried this and, although the firmware updated correctly, I could not initially get the Domino to be recognised in MFDeploy. However, I then noticed that the GHI.NET Micro Framework USB Debugging Interface had appeared in my computer’s Device Manager, but with a warning sign. Subsequently I updated the driver to this manually from C:\Program Files (x86)\GHI Electronics\GHI NETMF USB Driver Set and the Domino now works!

Many thanks for your help.



great to hear - mark your question as solved too !