Problems with Display N18 and others

Hi from Germany,
Since several years I’m watching your project to make it part of my lessons in school. Unfortunately there were too many problems to get it properly run for my pupils.
I baught several boards (Hydra, Spider, Cerberus) and updated firmware and the framework every now and then.
Now I gave it a last try and baught the Tinker Kit. I had to find out that it has too few memory to run the N18 Display. So I tried my Hydra board but this does not run either. The program gets deployed and starts to run but the display shows a complete mess.
The programm is made to set a line of pixels but what I get are two lines one blue and a white one which go from left to right.
I add the source code below.
The same program runs on the cerberus but only if I switch off the debugger because of lack of memory.
So I tried to update the firmware on 4.3 which worked o.k. except the display but the Tnybooter is still a 4.2 one.
The config - program says there should be a 4.3 version but the update with samba gave the same which was installed before.
I have a pc completely fresh installed with VS2012, NetMF 4.3 QFE2, Gadgeteer Core, and the GHI 2014 R5.

Thanks for help in advance


Here the source-code…

        displayN18.BacklightEnabled = true;
        // Does not work!!
        // displayN18.Orientation = DisplayN18.DisplayOrientation.Counterclockwise90Degrees;
        _xMax = displayN18.SimpleGraphics.Width;
        _yMax = displayN18.SimpleGraphics.Height;
        Debug.Print("Program Started");
        GT.Timer _timer = new GT.Timer(10);           
        _timer.Tick += _timer_Tick;

    int x=0, y=0;
    int _xMax,_yMax;

    void _timer_Tick(GT.Timer timer)
        displayN18.SimpleGraphics.SetPixel(GT.Color.White, x, y);
        if (x>=_xMax)
            x = 0;
            y = 0;



Hello Mflume

There is a known bug in 4.3 R5 of the gadgeteer sdk involving images that affects the display and camera modules.

See this thread for a workaround:

This is not [em]necessarily [/em]your issue (but maybe it is.)

@ mflume - The problem on the Hydra definitely sounds like the one mtylerjr linked. It has already been fixed for the next SDK.

I tried the R4 - package togehter with the Hydra - board and this works besides the fact that the x-coordinate goes from right to left.
I hope the R6? - version will fix this.
In general I would beg you not to change the names of classes, methods and so on anymore. I made some manuals and examples for my lessons and I have to rewrite them which is a lot of work.
Furthermore I would suggest to sell the Tinker - Kit at least with a Hydra board as the Cerberus has too few memory.
Additionally: You took some devices out of stock but some of these have been more simple ones which suitet well for school.
Now as the whole system runs much better than it used to do before maybe there is a chance to get a foot into the door of education. For this a long time reliable stock is very important.
For example: if I buy a set of 20 packages for a classroom I need a replacement guarantee for at least 2 years.
Maybe you also think about selling the blue boxes seperately plus screws and bolts for the holey-board.



Hi again,
Sorry I found the screws and bolts…



@ mflume - How do you have your display oriented where X goes in the wrong direction? Names should not be changing anymore unless there is a very compelling reason to do so.

I have the connector at the bottom (see picture).
The line grows from bottom/right to top/left.

Btw, it’s the R4 - Package

Some more info / questions…
I made the Pong-Demo from the Tinker Kit run on Hydra with the R4 - library with MF4.3
I runs normal besides the fact that the initial image (It’s bright here…) is not completely o.k. Then bottom of the game - where the paddle is- is on the opposite side of the connector just like the original on the Tinker - Kit.
Can it be that the coordinates in Y- direction go from top to bottom with increasing value?
Like they do in a PictureBox inside Visual Studion on Windows?

@ mflume - The picture you have shown is correct. The origin of the image is in the lower right of your picture.

Next question…
I made a project with Hydra and enc28 working as a tiny webserver.

Now I wanted to add the N18-Display.
The program gets deployed but after reboot I get the error message that SPI0 is already in use. I thing it is because of the presence of the ENC28.
The ENC28 is on socket 3 the display on socket 4.
Is there a way to use them together?

@ mflume - The ENC28 uses the SPI bus exclusively in Gadgeteer. Since socket 3 and 4 use the same bus, you cannot use them both at the same time when using the ENC28.