Main Site Documentation

Problems using the UP501 GPS with the FEZ Spider


#1

In picture 1 the GPS is connected to the USB client DP module, which supplies the GPS with a 3.3 voltage. The RX and TX on the GPS is connected to a USB to Serial interface which is connected to my computer by USB. I’m using Realterm to recieve information from the GPS. The setup in picture 1 works great, I get a lock almost immediatly and the position data is accurate.

In Picture 2 Instead of getting supply voltage and ground directly from the USB client DP module, I get it indirectly through the FEZ Spider motherboard. I checked the supply voltage over the GPS and current draw and its identical to the setup in picture 1. I would have expected this to work, but it does not. I recieve data from the GPS and I can send commands to it without a problem, but the GPS is not able to find any satellites.

Picture 3 shows how I want the setup to be in the end minus the two lose wires on the GPS-module. But as of now that setup is not working, the GPS is not able to find any satellites.

I’ve been trying for a few days now to get this working, but I’m completely stuck. Is there anyone in here that has any idea what might be happening?

Picture 1: http://i.imgur.com/3lIDitP.jpg Works great!

Picture 2: http://i.imgur.com/IaxfjHO.jpg Does not work, does not find satellites.

Picture 3: http://i.imgur.com/5qNAvg2.jpg Does not work, does not find satellites.

I should also add that no program is loaded into the FEZ Spider. Only thing I’m trying to do is to have the GPS find satellites and get position data while connected to the FEZ Spider.


#2

Welcome to the forum.

Check your grounds. There just be a common ground between all the devices. Also make sure only one device is proving power.


#3

@ Mike - Thank you for the welcome, and for the reply, Mike.

Both the USB client DP module and the USB to serial interface are connected to the same computer which provides a common ground. The only supply is from the USB client DP module. The USB to serial interface is supplied by its own USB but the GPS is only connected to the TX and RX inputs of that module.

I have also tried with the FEZ Spider alone with the GPS, where I output the NMEA messages to the Debug output in visual studio 2010. It gives the same result as in Picture 2 and 3: It does not find any satellites.


#4

@ kjelbyts - Sounds like the Spider is generating noise which kills the GPS receiver?

Try a bit of shielding? Separation?


#5

@ Mike - I think you are completely right Mike, and in adition I think the PCB adapter for the GPS is doing the same thing. Tomorrow I’ll dismount the GPS from the PCB and have it as far away from the FEZ Spider as possible. I did a quick test with a GPS without the small PCB adapter and it was working with the setup shown in Picture 2 with a distance from the FEZ spider of about 40 cm. Going to try the setup in Picture 3 tomorrow without the PCB adapter with a distance of atleast 50 cm and hopefully it will work.

Thank you very much for the suggestion Mike. I’m suprised on how much the FEZ Spider affects the GPS. Although I would call the UP501 hypersensitive.

I also found this topic of a user that seemed to have a similar problem:

https://www.ghielectronics.com/community/forum/topic?id=6356&page=1

I think it actually might have been the same problem. Therefore if other people in the future have similar problems, the first thing they should try is to increase the distance between the GPS module and the FEZ Spider.


#6

The Hydra issue you pointed to was explicitly a Hydra issue, and did not affect other mainboards. It’s unlikely it’s related to your issue at all.


#7

@ Brett - Duly noted, thank you for the reply.


#8

@ Brett - the hydra issue is with the seeed GPS module. in this situation, a different GPS receiver is being used.


#9

I think the Hydra issue is more than just Seeed GPSes, which is why Skewworks went to the trouble of making the Hydra-compatible one…


#10

I can confirm the Hydra wacks more than the Seeed GPS. I never got my GPS module (MTK 3329 with internal antenna) to work with it. The Hydra does work with another GPS (MTK 3339) I have that has an active external antenna.