Main Site Documentation

Problem with GHI Bool Loader Interface


#1

Hello,

I have Windows 7 x64 with all patches and service packs installed. I can access to my panda Boot loader. I hold LDR button and restart panda. In device manager Debuggable .NET Micro Framework Device go away and new com port shows. But this com port have (GHI Bool Loader Interface) have ! beside. If I open properties in device status i get:
This device cannot start. (Code 10).

I already tried to update driver manually and also to uninstall it with “Delete the driver software for the device” selected withou success.

If I conect to this port using TeraTerm I can write but I don’t get any response from the device. USBizi updater give me this message:
– Log –
Connecting to device…
Cannot connect to the device! Follow steps 1 to 3

What else can I do? I have same problem also with FEZ Spider.


#2

Try manual update instead


#3

I can’t. If I open Com port 3 with Tera Term VT I can type commands but on press enter nothing happens. Cursor just jump to start of the line (not new line, like in GHI manuals).
I tried commands:
V, E. I guess Panda II don’t get these commands.

What else can I do?


#4

Not sure, maybe try another PC.


#5

That typically means that there is some issue with the driver. If you can, try reinstalling the driver from the device manager page. You might also find other hints in the event log that tell you why it didn’t start - perhaps it hasn’t grabbed a random COM port but one in use?


#6

Thank you for your replys. I already tried to uninstall drivers and also to change COM port to someting else (like COM35). With no success. Any other idea?


#7

replace the micro USB Cable you are using and use the one shipped with your Spider… also make sure you are using a powered USB HUB…

i had a similar problem earlier where the cable i was using was working fine during deployment and debugging but when i switch to updating the firmware, and got to the bootloader interface i had similar issue with the com drivers… i changes the USB cable and suddenly it all worked…

Cheers,
Jay.


#8

This has to be a coincidence.

You should always use a powered hub for all your devices for best results, instead of replying on the PC power.


#9

Hi Gus,
Maybe, but in my test it was consistent… before i flashed the firmware i tried both cables multiple times, the one i have gave the com issue and MFDeploy couldn’t see the the board… but when i switch the cable and use the one i got with my Spider, MFDeploy detected the board and the com issue disappeared in Device Manager… i switch back and forth more than 5 times… i even tried other cables i had here… and some worked and others didn’t so i know it has something to do with the cable used…

the differences in the cable are as follow:
even thought the cable i have is thicker 24AWG, it didn’t say anything about whether it was shielded or not, i suspect not… where the one i received with my Spider has making stating it is a Shielded cable…

maybe others can try this theory and report back.

Cheers,


#10

Dodgy cables are, well, dodgy. The cables GHI ship with are great cables to use, as are the ones that come from other hardware manufacturers (like with a phone or a tablet). The dodgy, cheap, $5 for 3 cables on ebay deals are cheap and certainly prone to other issues. I have both, because I am cheap :), and I have now started putting some white-out (liquid paper) on the GHI cables so I know the reputable ones.


#11

I tried to power Panda with different source and also change USB cable. Without success.
But when I tried to update firmware normaly I get only “Cannot connect to the device”, but this time I get USBizi found, but just after that Cannot connect to the device…


#12

Yep the cheapos, i have those as well, i guess i must be cheap too ;D

and one more thing I’ve experienced…

if you use the spider for example and decided to go to the hydra, unplugging the spider and plugging in the Hydra will cause that com error. even in VS2010 it will cause issues… even tough it detects the hydra just fine. for whatever reason it doesn’t work…

so i found out works is plugging the Hydra in this instance to a different USB Port… forces windows to reload the driver because i do get that Driver certificate when i do this…

the same happened when i was deploying to the Spider and decided to try something on the Panda… i unplugged the USB cable from the Spider and plugged in the Panda and i got an error in VS… when moving the panda to a different port it worked fine.

cheers…