Main Site Documentation

Problem with getting started the Cerberus and Cerb40


#1

Hi,
I have bought your set of development of Cerberus and Cerb 40.
Following supported descrition I installed the developing environment: I filled the linked materials according to (based on) the signed link.
Unfortunatelly I could not manage to fill the most simple program either I used gadgetter template nor using consol (without template).
After downloading code I have received the (error) message:

Create TS.

 Loading start at 8036fc8, end 804b620

Assembly: mscorlib (4.2.0.0)Assembly: Microsoft.SPOT.Native (4.2.0.0)Assembly: Microsoft.SPOT.Hardware (4.2.0.0)
Assembly: Microsoft.SPOT.Graphics (4.2.0.0)Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0)
Assembly: Microsoft.SPOT.Net (4.2.0.0)Assembly: System (4.2.0.0)Assembly: Microsoft.SPOT.Hardware.Usb (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1)Loading Deployment Assemblies.

Attaching deployed file.

Assembly: GTM.GHIElectronics.Display_HD44780 (1.0.1.0)Attaching deployed file.

Assembly: GTM.GHIElectronics.Joystick (1.0.1.0)Attaching deployed file.

Assembly: Gadgeteer (2.42.0.0)Attaching deployed file.

Assembly: System.Http (4.2.0.0)Attaching deployed file.

Assembly: GHI.OSHW.Hardware (4.2.3.0)Attaching deployed file.

Assembly: GHIElectronics.Gadgeteer.FEZCerberus (1.0.6.0)Attaching deployed file.

Assembly: Microsoft.SPOT.Touch (4.2.0.0)Attaching deployed file.

Assembly: GTM.GHIElectronics.LED7R (1.0.0.0)Attaching deployed file.

Assembly: GadgeteerLight (1.0.0.0)Attaching deployed file.

Assembly: Microsoft.SPOT.Net.Security (4.2.0.0)Attaching deployed file.

Assembly: System.Net.Security (4.2.0.0)Attaching deployed file.

Assembly: Microsoft.SPOT.TinyCore (4.2.0.0)Attaching deployed file.

Assembly: System.IO (4.2.0.0)Attaching deployed file.

Assembly: GTM.GHIElectronics.MotorControllerL298 (1.0.3.0)Attaching deployed file.

Assembly: Microsoft.SPOT.IO (4.2.0.0)Resolving.

Resolve: unknown type: Microsoft.SPOT.Touch.TouchScreenEventHandler

Error: ff000000

Waiting for debug commands...

The program '[2] Micro Framework application: Managed' has exited with code 0 (0x0).

This error exists in the case of Cerebrus and Cerb40 (using updated win8, win7 posready, win7, even table pc and notebook).

I looked after in the internet and I have found an error that is similar to my problem:
http://www.tinyclr.com/forum/topic?id=8368.
I have done the suggested solution, but it did not work. According to the last comment the problem is fixed but it does not seem to me.

Help me pls.


#2

Make a new project and do not modify it at all. Can you upload it?

Welcome to the community.


#3

Yes, new project, start debug, error msg too:

Resolve: unknown type: Microsoft.SPOT.Touch.TouchScreenEventHandler

Error: ff000000

I’m not using touchscreen :slight_smile: My problem is similar [quote] http://www.tinyclr.com/forum/topic?id=8368[/quote]


#4

Did you do firmware update?


#5

Problem solved. Very thanks for Your help.


#6

Hi,

I have exactly the same configuration as _tz and I get the same issue. Could you please tell me how you fixed this ? Does it have to do with a firmware update ?


#7

Problem solved, I updated the firmware by following these steps : https://www.ghielectronics.com/docs/55/firmware-update-fez-cerberus#537


#8

@ lgaland01 - glad it worked for you

welcome to the community.