Problem updating Hydra+ via FEZ Config

I have a brand new FEZ Hydra+ that I am attempting to update for the first time. I am having some issues trying to see if the board needs an update and updating it. I have tried all of this with and without an external power supply attached to the USB Client DP module.

FEZ Config, sees the board, and a ping results in TinyCLR. But when I attempt to check the device for update, it either gives me a “no response from device” error message, or it reports that TInyBooter is (up-to-date), that TinyCLR is “not present on the device,” and that the device is in Loader mode. If I reboot the CLR as suggested, I can ping TinyCLR. I’ve tried these steps a few times, and cannot get the device to say what version of CLR it’s running.

Guessing that, since the TinyBooter is up-to-date, the board might benefit from a reload of the firmware, I attempted to go the Firmware Updater route. 80% of the time, after a brief delay, the device’s firmware version is reported as not being present and that the board is in loader mode. 20% of the time, the device’s firmware version is reported as Either way, if I attempt to reload the firmware, everything looks like it’s going to work (the progress bar is moving), but eventually I get “Hydra updating failed!”

So, I think I probably might possibly have the latest of everything on the board, but this odd behavior worries me - that I might have corrupted/partially-loaded firmware on the board, and don’t seem to be able to refresh it.

Is this normal behavior for this board, or am I missing a step somewhere?


Added Note: I notice that whenever it says “no response from device,” the green debug LED on the board winks once, and the device name disappears. But as soon as I dismiss the error dialog box, the device name reappears in the FEZ Config Connection window. Don’t know if this is relevant, but thought I would add it just in case.

I believe what you are experiencing is a known issue with the Hydra and Raptor which John has been working to resolve. Hopefully, there will be a fix out soon.

1 Like

@ ianlee74 -

Thanks. In spite of the inconsistent behavior and the failed updates, is it reasonably safe to assume that I can use this mainboard? So far, it appears that deploying and debugging small applications works, but if it’s in a vulnerable state, I don’t want to pour too much into it before it’s fixed.

I don’t know what details John has found but I believe the problem is isolated to updating the firmware. Once that’s done successfully and you move back to Visual Studio then you shouldn’t have regular issues. It is a big nuisance, otherwise, and one I hope will be remedied soon. I’d give it a try and see if the problem persists once you leave FEZ Config.

1 Like

Try doing a reboot CLR from the MFDeploy, main menu -> Plug-in -> Debug -> reboot CLR as there is an outside chance it might help.

1 Like

@ Duke Nukem -

Thanks. I have tried the Reboot CLR from MFDeploy and from the FEZConfig menu several times, and continue to get the same behavior.

ianlee74 -

Thanks. So far, I haven’t seen any odd behavior when deploying/debugging/running a Gadgeteer application.