Main Site Documentation

Problem update tinyclr raptor


#1

Hi,

I am having problem to update my raptor to tinyCLR version 4.3.6.0

I used the SAM-BA v2.12 with the update.bat files. the tinybooter update worked has expected.

Then I use Fez config to update the tinyCLR with the firmware updater the process is successful. But my raptor is still with no tinyclr in it. I also use the advanced REBOOT CLR but it doesn’t work. There are still no tinyCLR

thanks


#2

@ Mano -

You need to run the Firmware Updater. The loader is the hard part…
See image.

See https://www.ghielectronics.com/docs/127/firmware-update for the loader.
Main thing is the need to jumper a socket to create the serial port for the loader.

https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400

G400 SoC products: Ground PA11, reset or power cycle the board. With power still ON, unground PA11

FEZ Raptor mainboard:

connect the board to the power supply and computer, 
locate socket 3,
on socket 3, connect pins 8 and 10 with a wire,
press the reset button on the Raptor board,
remove the wire ("unjumper") from pins 8 and 10

In either case, be sure to unjumper the FEZ Raptor board or the G400 processor within 3 seconds.


#3

Thanks that’s what I did the tinybooter is updated but I’m not able to update the tinyclr it is empty as you can see on the print screen


#4

I’ve experienced the same problem with two Hydra boards. They have been updated but FEZ Config shows this message each time. Try deploying a simple project, I used a new empty one, and check that it deploys correctly.