Main Site Documentation

Problem installing bootloader driver


#1

I’m having trouble installing the bootloader driver for my FEZDomino board. The board itself has firmware version 4.0.2.0 installed and I’m trying to upgrade to .NETMF 4.1 and firmware 4.1.1.0 in the hope it will solve the problems I’m experiencing with SPI.

The NET MF interface driver installs with no problem. When I try to install the bootloader interface it fails with the message:

‘A service installation section in the INF is invalid’

What do I need to do to update my firmware?


#2

You are probably using the wrong driver.
Follow steps in downloads, user guides…etc to :
Uninstall any existing version and SDKs you have.
Install visual studio 2010, NETMF 4.1, our latest SDK.
There are automated driver installer in downloads.


#3

I installed Visual C# 2010 Express, .NET MF4.1 and GHI .NET MF SDK in that order.

I’m installing the driver from

c:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface\

that should be Ok, right?

When I uninstall I go to Device Manager and under Ports there’s a USBizi entry with a yellow exclamation mark. I right click it and select ‘Uninstall’.

What’s wrong with that?


#4

I just want to add that I don’t have any serial ports on my PC. Could that be the problem?

I just found out that I don’t have the usbser.sys driver on my machine. Should this be included with the GHI SDK?


#5

Solved it! I downloaded the usbser.sys file from http://mark.cdmaforums.com/Files/usbser.zip and copied the usbser.sys to the Windows\System32\Drivers directory.

I then tried to reinstall the Bootloader driver again and it worked without a hitch. ;D


#6

What led you to that solution?


#7

It complained about an invalid service section in the INF file. I concluded from looking at the INF that it had to be the usbser.sys not being present, and that turned out to be the case.


#8

Well, since that is a system file I’m really surprised that it was not on your machine already. What OS are you using? I see there is a 4 year old hotfix out for XP for a similar issue but would suspect if your running with the latest service pack (3) you should not have had this issue.


#9

I’m using XP SP3.

I just found out that it’s in

c:\WINDOWS\Driver Cache\i386\driver.cab

and I guess it’s installed by Windows when it’s needed or something.


#10

if you are using a scaled down version of XP you might not have some dlls installed.