Main Site Documentation

Problem for to work with socket in .net microframework sdk 4.2 on os w7 for netduino


#1

I have a problem with the installer of .NET Microframework SDK 4.2. I work with OS Win7, Visual Studio 2010 and I have downloaded the programs for to work with Netduino plus 2 from official website. I am doing test of exception error on the code and when I run the code line of the socket the program stops and exits the compiler. Obviously I want to treat socket error when network cable is disconnected but I get the error mentioned above.

Deputy of the code to treat socket exception error.

Main()

Try

   Socket.Connect()

   flagException = False

   Debug.Print("Connected Socket")

   'following code

   ' ERROR CONECTION TCP-IP ==> System.Net.Sockets.SocketException

   Catch errorSocket As SocketException

   'Socket.Close()

   'Debug.Print("ethernet connection")

   flagException = True

   Finally

End Try

   Thread.Sleep(Timeout.Infinite)

End Sub

When it is evaluated several times to check the network connection crashes the program and set no exception error. Can you help me? Thanks


#2

Networking support is part of the boards firmware so since it’s a Netduino you will need to talk to them for trouble shooting.


#3

Salutations Bill

The problem is in the Micro Framework SDK 4.2 under W7 as are those who manage libraries Netduino functions. When working in Windows XP there is no problem in working errors that may occur in the Netduino but changing to Windows 7 is when you have the problem above. It is desirable that could fix this in order to continue working with working under Windows platforms.Thanks for your answer.


#4

Interesting. So the same code, same SDK, same Visual Studio, but when compiled on XP it is working and when compiled on W7 is not working.

Have you tried deploy it under W7 but running it without the VS attached. I wonder if it is a driver issue.


#5

when is a program where not is working Sockets with then the debugger works. The problem is when running the line of sockets and not connected the network cable. In XP the program sets the Socket exception error but when is running with W7 not shows nothing error and closes on VS 2010. I’ve also tested with VS 2012 and gives the same problem.

I think the problem is in the installation of the Micro Framework on W7 of 64 bits because libraries are not containing the. NET. If por example, I want testing that the network cable is connected in each time, it not is posible. I have tested in multiple computers on W7 and it not works. I’ve tried with the programs downloaded directly from the website of Netduino and from the website Micro Framework with the version required, and in any way does not work.