Problem connecting to a beaglebone black through USB

I’m running into a problem connecting to my BBB through Putty, WinSCP, and using the IP address ( in a browser. I think my problem is that the driver (BONE_D64) isn’t installing correctly. I’m using a Windows 10 machine and whenever I try to execute the 64-bit installer from the BBB, I receive an “Install Failed” message under the Status section at the end of the install wizard. Does anyone know how to solve this problem with the network-over-USB access?
Thanks :slight_smile:

@ chenselman - Have you tried plugging it directly in or though a powered hub? Just in case it is a power issue.

@ Gus -
Yes to both. I am connected directly to my computer which has a powered hub. I know it isn’t a power issue because I can see the LED’s lighting up on the BBB and the weird thing is I can see the Beaglebone files in my D: drive in my computer. The problem is that it won’t connect when I try to use Putty. I disabled the secure boot and temporarily disabled the driver signature checker and was able to successfully install the driver for network over usb connection from (inside the bbb) but when I check the driver in my device manager it shows that the digital signer is microsoft windows instead of foundation. Is it possible the windows driver is overriding the driver? If so, how can i disable the windows usb driver?

In Windows 10 Device Manager, when plugging in the USB cable, see under “Other Devices” RNDIS and under “Ports” “USB Serial Device (COM3)” both appear at the same time. Refer to Redirecting Windows 10 vs Remote NDIS - Ethernet USB/Gadget not recognized, for further information. Note that BONE_D64.exe fails to install all four drivers on Windows 10. You can force a USB RNDIS/NDIS driver to install but it will not be reliable and even less so on an up-to-date Windows 10 PC. Windows 8 and earlier may be more successful. Other methods of connection using a FTDI USB to serial, crossover ethernet cable or joining a home network are more appropriate methods of connection. I use the serial connection and I also use a network connection.

@ KG1 -

You need the RNDIS driver.


This worked for me when installing for Windows 10 Pro.