Main Site Documentation

Porting NETMF 4.4 to an STM32F4


#1

Hello Everyone,

Having shortage issues with the G30 so I am looking into porting NETMF 4.4 to a blank STM32F4 to hold us over. Where can I find the appropriate files/compiler to accomplish this? I read through the “Beginners Guide To Porting NETMF,” as well as this post here but I am pretty confused as to which files go where.

I am trying to build the solution for the STM32F4Discovery in this port kit located on Github. I keep getting guild errors from not being able to locate assemblies, even though I downloaded the .msi file in the “Releases,” section on GitHub.

image


#3

Try this: https://github.com/Dweaver309/NETMF4_4FirmwareUpdate


#4

@dweaver Wow thank you, definitely the most straight forward guide I have seen after days of searching…all install files in one place too!

In step 3, where it says to install the binary tools, does that just mean unzip them into the folder or is there an application in bin or tools that I must run? When I call setenv_gcc it says it is not recognized, I didn’t install any GCC files, I just unzipped into the directory C:\gcc_4_9_3 like the instructions say.

image

Also how do I adapt your FW for an STMF32F401 once I get this version to build?


#5

Install binary tools is step 5 when the build-tools.zip file is unzipped in the C\netmf the two dircectories bin and tools are created.

  1. Install the binary tools to this directory C:\netmf
    http://netmf.github.io/downloads/build-tools.zip

You need a create a new solution in this directory
C:\netmf\netmf4_4_0\Solutions

Copy one of the current solutions and rename it.

Edit the platform_selector.h file to match the chip properties.

Then edit one of the .bat files for your solution.


#6

Sorry, I meant step 5. Yes I unzipped them to that directory.

I think I am doing something wrong with the GCC part. Should GCC be in C:\gcc_4_9_3 or in C:\netmf\gcc_4_9_3 ???

it says it can’t find the setenv_gcc command


#7

C:\netmf\gcc_4_9_3


#8

you can install whenever you want in C or inside working folder

look picture on

https://github.com/Dweaver309/NETMF4_4FirmwareUpdate/blob/master/Dir.png

how shuld look directories (for easy setup and work)

and just edit GCC.STM32F411NUCLEO.bat and rename with soulutions and use inside folder netmf4_4_0

and setenv_gcc,cmd is inside netmf4_4_0 too


#9

sorry I think there is a typo in step 6 image

I will change to C:\netmf\gcc_4_9_3


#10

here is my set up now:


#11

That looks right.


#12

still getting this error, I am not good with command prompt:

image


#13

do I have to actually install GCC or just unzip it into C:\netmf\gcc_4_9_3

this step worked on the other build I was messing with using setenv_mdk, I am not sure if GCC need additional installation or somthing


#14

6.Create this directory c:\gcc_4_9_3 and unzip the CGG ARM compiler into the directory. https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q3-update/+download/gcc-arm-none-eabi-4_9-2015q3-20150921-win32.zip


#15

just unzip on C:\netmf\gcc_4_9_3

and it should look like this picture

and setenv_gcc reside inside folder netfm440


#16

Got it! had to go one folder deeper into netmf4_4_0


#17

@dweaver @valon_hoti_gmail_com

image

it says my CMSIS isn’t installed but it is right there in netmf4_4_0, is it because it added a second subfolder called CMSIS?


#18

there is already a CMSIS folder in netmf4_4_0, do I unzip the CMSIS files in the already existing folder?


#19

This is what the directory tree should look like


#20

@dweaver Ok I have that. still getting an error when I call this line:

cd Solutions\STM32F411NUCLEO msbuild /t:build /p:flavor=release;memory=flash /fl

this is actually what happened with the other build I tried. It gives 140+ errors during the build saying it can’t find Microsoft.Spot.Tasks and the .dlls it contains

I am thinking of re-installing vs2015

image

here is what I have installed:


#21

Are you using the batch file GCC.STM32F411NUCLEO.bat for your build?