Main Site Documentation

"Please check your hardware"


#1

Hey guys,
Any clue what a “An error has occured: Please check your hardware” during deployment means?

I’ve tried two different boards and I’m getting the same problem.


#2

More data: I’ve tried uploading a “Hello World” program onto it, rather than my full program I was trying earlier - It runs, but nothing is returned in the immidiate window. When debugging a for next loop, the counter increments, but once again is not debugged if I do debug.print() on it.

EDIT: The problem occurs on all my boards, even ones that I have not modded, (Pandas). Breakpoints and variable inspection works.

More info: Immidiate window works on my laptop, but I still get an error regarding “Please check your hardware”. The setup on both my laptop and PC is pretty much identical as far as I am aware. Windows 7 64bit, 64bit drivers, Visual Basic Pro…

Maybe I messed up installing the SDKs somehow… I’ll try reinstalling those.


I’ve reinstalled every single piece of software that’s used here, still the same problem persists.

Another thing I’ve noticed, even my emulator is not displaying anything to the immidiate window.

Even more info: A lot of the time when trying to pause the program execution I get an error saying: “Unable to break execution. This process is not currently executing the type of code that you selected to debug”.


#3

Have you updated the firmware of all boards? It should match the SDK version.


#4

Yes I have. all SDKs/Firmwares match.


#5

I once had the same problem and a fix was to create a new project and copy paste all classes to it.


#6

Get this error quite often. Mostly a “hard reset” (unplugging every power supply, including usb) works.


#7

Reasons for which I’ve got that message include:

[ulist]Accidentally switching to a different deployment transport.[/ulist]
[ulist]Trying to deploy right after using the bootloader in a Panda II (when the system still sees it as a COM port.[/ulist]
[ulist]When the combination of my executable plus the referenced assemblies exceeds the storage capacity of the device.[/ulist]
[ulist]Visual Studio goes through an existential crisis and has to be restarted.[/ulist]
[ulist]The sometimes too-common whimsical out-of-the-blue-have-to-reset-the-device-for-who-knows-why instance. ;)[/ulist]

There are times when the messages in the [italic]Micro Framework Device Deployment[/italic] output window provide useful information.


#8

I got that error when I had 2 projects in a solution that targeted different devices (Mini & Panda II) and it loaded the wrong one. It frequently ignored which project I had selected as the startup project and every time that happened it would give me that error, and I would have to erase the device. I ended up with 2 solutions so that I wouldn’t have to keep dealing with it.


#9

Gralin - Thanks for your input, that fixed it.

Weird, I guess some incorrect setting was cached somewhere in the old project.

Any clue as to why I might not be getting any immidiate output out on my PC? Everything works perfectly, I can deploy, breakpoint, inspect values etc, just nothing in the immidiate window. Is there some kind of a setting that assigned the immidiate window to the debugger, or something like that? I’m sure it’s something simple.


#10

Do you mean to the output window? The immediate window is for running simple functions when you have hit a breakpoint and are stepping through code. Nothing gets output there except the results of a function you run. For example, you can use it to look at objects that are in scope, or change the values of those objects.


#11

On my laptop all messages that are debugged using Debug.Print(“This is a debug message”); appear in the immidiate window - I assumed this is normal?


#12

Not default, but you can redirect output to the immediate window. I suggest you also open the output window to see if anything ends up there. This post makes me wonder if “All Output” really means everything.


#13

Thanks, I’ve never worked with microsoft products before NETMF, so I’ve only got the experience that I gained while working with FEZ stuff - Never looked around the options too much.

I’ll try that out and let you know how it goes, for some reason on my laptop that output went to immidiate window by default.


#14

You were right eric, it was in my output window - I can’t understand why it’d be there on here while in the immidiate window on my laptop - I didn’t touch any settings…

Thanks for all.