Main Site Documentation

PANDA2 - Inserting/removing SD card resets the board?


#1

Hello !

I have a problem with my Panda2 board.
Whenever I insert or remove an SD card, the boards resets (exactly like when the reset button would be pressed). I tried with several SD cards.

On a Domino board, I don’t have this problem, with the same SD cards.

The program running is just the default blinking leds.
I tried with USB power of +6V DC power, debuging with USB or serial, or no debugging at all…

Is this a “feature” :smiley: ?

Thank you in advance !


#2

This shouldn’t happen if you power the board from external power! On USB power, it is possible.


#3

Investigating the problem.

I am on external power (tried 3 different external power sources between 6v and 9v).
No other hardware is connected to the panda2 (no sensor, shield, or anything).

Not related to the reader micro switch sensor : if I toggle it manualy with a piece of plastic, or bring the pin to ground with a little wire, no resets.
Hard to see if the 3V3 is steady during inserting : My scope is out in the fields for 2 to 3 more weeks, and the meter is not accurate enough to see if the voltage is going down for a few microsecs…

The SD cards I am using are brand new Sandisk 8GB SDHC. They work fine with my Domino.
Once they are inserted in the reader, I can read the SD files without problems.

Any clue :o ?


#4

Drop a capacitor between 3.3V and GND pins and see if this changes anything.


#5

Tried 100nf, 1uF and 100uF, no change.
I wonder if my 3V3 regulator is working well. It is providing 3V3 but if while the board is running I manualy add a 100uF capacitor between 3V3 and GND (should load quite a peak current !), the board is resetting the same way as when I insert or remove my SD card.


#6

If I use a 100uF decoupling capacitor on the SD card reader AND I upgrade C3 (NXP chip decoupling capacitor) to 100uF (a big gun to kill a fly…) then I don’t see the problem all the time any more 8) (only once every 3 insertion).

If I use only one capacitor (either side) I have the problem.

Do I have a problem with my 3V3 regulator ? ::slight_smile:


#7

If I put 100uF and 100nF in // on the SD card reader, the problems disapear completly. If I only have a 100nF there I have the problem all the time.

I think if I could insert a small coil between 3V3 and the card reader, it would solve the problem more permanently.

Do you guys want a 8GB sandisk SD card to do tests at your labs ?


#8

Looks like your card is power hungry on power up causing a little surge that is reseting the micro. We will look into this in future builds.

I do not think the 100nF is needed.


#9

However if I remove the 100nF capacitor, it is working only 2 third of the time !
I understand that 100uF + 100nF === 100uF, however in dynamic, they are both cutting a different frequency…

Just let me know if you want me to ship you a SD card of the same type for your tests - I’ll ship you one :slight_smile:

PS : on the domino board, you have a 10uF decoupling capacitor touching the SD card reader, that may help ?
Also I found out that the grounding of the 3V3 regulator is better done on the domino : many pass-thru holes arround it. That may also help. I would finaly advise to put in // close to the NXP chip two parallel capacitor : 10uF and 100nF which would prevent oher problems (especialy if a shield has current peaks). If possible closer than C3 currently is from the NXP.


#10

Thanks for the feedback. We will investigate further and let you know if we have questions.


#11

I have exactly same problem with my new Panda II (Rev D) with latest SDK and firmware. It reset board both when inserting or removing card.

I tried with 2GB and 4GB SanDisk and 2GB Transcend MicroSD cards.
I tried powered USB hub, Direct USB on my desktop and notebook, 6V 500mA and 9V 600mA external power adapter.

When inserting, it reset board two times:

  1. Right it the beginning of inserting, if you push it gently
  2. After you pushed all the way, when you release (right after click-lock)

When removing, it reset board after first click-unlock.

So, I got defective board? =)


#12

No your board is not defected. It seem that the cards we have used in testing do not have high inrush current and do not cause this behavior. The fix is by adding a capacitor like Nick explained.


#13

What cards did you use for testing? I’d like to try them to make sure.


#14

Hello Savvkin, and Thank you, I feel little reassured that I am not the only one having the problem… :-[

Please note that I added 3 capacitors to fix the problem definitly for all the SD cards I have tested. 100uF is way too big (I had only this one on my desk and too lazy to go hunting ;)), so try with 10uF. Add one between pin 4 and pin 6 on the SD reader, plus one in parallel with the existing C3 (close to the NXP chip). Watch for polarity ! If you still see the problem, add a 100nFin parallel with the 10uF on the SD reader.

I’ll make further tests when back to the lab next week :slight_smile: