Main Site Documentation

Panda stuck in Bootloader mode


#1

Hello all,

I was “playing” with IFU, thanks to the great help of Skewworks, but now I have what I think is a big problem : the board is stuck in Bootloader mode :frowning:

Each time I plug/unplug it from the PC, it does not show as usual [italic]GHI debuggable .NetMF device[/italic] but rather as [italic]GHI Bootloader interface (COMx)[/italic]

I think this is because I didn’t put the AccessApplication() call in my code, but I’m not sure.

Of course, in this state, I can’t upload/deploy anything ???

I’ve tried all this with no success :

  • erase the board with bother “E” and “D” commands
  • put the firmware again on the board, but I have either “Bad Firmware” message with tons of “BL” lines or the transfer window stays at Packet #1 for 30sec and then disappear without doing anything
  • if I type command “V”, I get 1.07, which seems to say that the board is still responsive

Does anyone know what I can do to reset the board or at least make it start in normal debugging mode ?

I must say I feel particularly ashamed on this one :-[


Christophe


#2

Ahem… kof :-[

Well, how could I say that ? :-[

I have plugged an external power supply in the Panda and finally succeeded in flashing the board :whistle:
Like a beginner :wall:

This one will also go in a good place in the FAQ :hand:

Gus, could you please remove 129 exp points from my score ? I think I deserve some punishment for this one ???


#3

You are a bad boy … ;D


#4

It happens. Spent a lot of time trying to figure out an issue, that was a really stupid mistake on my part. :-[

Glad it worked for you and your panda is alive. 8)


#5

What is annoying is that it’s not the first time it happens to me :wall: I should have paid more attention to this but I was concentrating on IFU and forgot the basis :frowning:

I’m going to get this phrase tattooed on my hands : CONNECT EXTERNAL POWER SUPPLY, DUMMY !
And maybe stick a small flag on each of my boards…


#6

Well Bec a Fuel, you are not the only one. I too am stuck in Bootloader mode and unable to recover. I wasn’t even doing any strange code development either - simply removed the serial debug jumper to go back to USB debug to test some other code.

I think I’m missing a step or detail in your earlier solution. An external supply is mentioned in this thread, but simply connecting to an external supply doesn’t change the board (a Domino in this case) from coming up in BL.

Any suggestions or more detail? Your help is appreciated.


#7

Just checking back in - Is there any help for this problem?


#8

Please explain the details of what is going on, possible in new thread. You replied to a 3months old thread :slight_smile:


#9

Thanks, Gus. I’ll start a new thread.