Main Site Documentation

Panda Not Found


#1

My computer does not recognize my Panda. I installed all of the files suggested in the beginner’s guide (as downloaded from the tinyclr downloads page), and also installed the USB Drivers Auto Install.

Stepping through the beginner’s guide, I ran .NET MFDeploy and plugged in the Panda. There was no reaction from the OS or MFDeploy when I plugged the device in. Also, I chose “USB” under the Device drop down list. According to the beginner’s guide, the Panda should show up in the drop down list to the right of the Device drop down list, but this drop down list is empty.

Is there a step I missed? What could I be doing (or not doing) that would prevent the Panda from being recognized by my computer?

Any help will be greatly appreciated!

Richard


#2

Hi there Richard,

seems like the OS isn’t detecting the device at all.

I have just plugged my Panda in for the first time, and two things happen. First, the LED on the Panda came on, and then once the test program started that LED started blinking. So can you tell us if that happened on yours? If not, perhaps it’s a cable issue. Do you have another cable to try? I’d also try connecting to a different USB port on your computer, and I’d also try removing a hub and connecting direct if you were doing that.

Another possible test is to power the device not from USB but from the 2.1mm power jack if you can - 7-12v DC. Again, the Fez LED should come on when you plug it in.


#3

Control panel > system > device manager

Is your panda recognized there? If not, select to update the driver and select the driver in:

c:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers


#4

I just went through the same thing with my Domino a couple of hours ago. It turned out to be a bad cable. I was using one that I had lying around and it didn’t work. The GHI supplied cable fixed the problem.

If you are using a hub, try connecting it directly to the PC USB ports.

-Eric


#5

Switching USB ports got it working. I was under the impression that all of the USB ports on my computer are the same, but now I know better!

Thanks to all of you for your suggestions!


#6

This is why these forums are soooo… good!!

Problems experienced by some… helping others…

Its brilliant… I hope your dabbling goes well.

Cheers Ian


#7

I haven’t get a chance to play with my Panda up till now. I connected it using a third party cable and it didn’t even get detected. Switching to the cable that came with it solved the problem. The cable I originally used is for Blackberries…

I though all cables are born equal?


#8

Hi all,

Just starting to work with VS2010 and FEZ Cobra. Installed everything, FEZ detected, download program => OK. Then suddenly the message USB device not recognized displayed and FEZ cannot be reached anymore. Switching off and back on, disconnect and reconnect, remove & reinstall drivers nothing helps.

Connecting the FEZ directly to another port on the PC fixed the problem. Initially I had the FEZ connected to an USB hub.


#9

I found that some hubs do not supply the normal 500mA (max) …The cheaper ones will only give up to 250mA. Not enough for a cobra… I had to buy a 10 port hub will a guaranteed 500mA per port.

Cheers Ian


#10

This is correct. Some (mostly cheap) hubs do not supply enough power.
The best way is to get a powered hub (the ones with a wall wart)