Main Site Documentation

PANDA III USB connection failure


#1

Hi.

I’m not good at English.

I received PANDA III and COBRA III last weekend.
At first time, it worked well.
But I’ve got USB connection error with PANDA III after uploaded my code in Visual Studio 2015 with MF 4.3.
When I connect PANDA to PC using micro USB port, my PC plays device connection sound, and a few seconds later,
the Device Manager reports Device Descriptor Request Failed with error code 43.
I think it’s not USB power problem. there no connection problem with my other COBRA III, and PANDA also connected well before.

To reset firmware, I tried to switch to GHI Bootloader.
Then Device Manager detected GHI Bootloader (COMxx) well, but there no response from device. (Loader Update in FEZ Config, putty terminal too.)

The code that I uploaded has a StackOverflowException, I don’t know this code causes connection problem.
The only thinkg I did was I connected GND, COM1 TX, RX pin to my drone for 3.3v TTL commuication.

What can I do in this situation?


#2

Disconnect everything and only connect USB. Restart your PC also.

Now, what happens if you try to update the firmware?


#3

@ Gus - I already rebooted my PC many times and reconnected PANDA alone.
And also tried to connect to another PC and I got same result.

I just tried to reset firmware to clear my application.

Is there any problem if managed application have stack overflow procedure like bellow?

static void Main() { DoSomething(); }
static void DoSomething() { DoSomething(); }

I don’t think that managed application causes connection problem, but when I execute some codes like above on emulator, emulator has crashed with GC failure due to too large memory has been allocated for call stack.


I tried to switch serial debug mode and i’ve got following messages using terminal.

G80
Version: 4.3.8.1
Debug: COM1
LCD: 0x0
.NetMF v4.3.1.0
G80, Build Date:
Mar 28 2016 08:14:04
ARM Compiler version 410713

TinyCLR (Build 4.3.1.0)

Starting…
Created EE.
Started Hardware.
MSdbgV1R▒▒ cW}Create TS.
Loading start at 80826d4, end 80a8660
Assembly: mscorlib (4.3.1.0) Assembly: Microsoft.SPOT.Native (4.3.1.0) Assembly: Microsoft.SPOT.Hardware (4.3.1.0) Assembly: Microsoft.SPOT.Graphics (4.3.1.0) Assembly: Microsoft.SPOT.TinyCore (4.3.1.0) Assembly: Microsoft.SPOT.IO (4.3.1.0) Assembly: System.IO (4.3.1.0) Assembly: Microsoft.SPOT.Hardware.Usb (4.3.1.0) Assembly: Microsoft.SPOT.Hardware.SerialPort (4.3.1.0) Assembly: Microsoft.SPOT.Hardware.PWM (4.3.1.0) Loading Deployment Assemblies.
Attaching deployed file.
Assembly: TestOnBoardSDKMF (1.0.0.0) Attaching deployed file.
Assembly: DJI.OnBoardSDK.MF (1.0.0.0) Resolving.
Ready.
@ b▒ĄG3▒!▒CN▒▒▒D3B)▒CN▒▒▒D3Bs!)▒▒ik’F؄▒ą▒▒▒b▒▒▒▒▒▒▒▒D3B!▒CN▒▒▒E3B!▒CN▒▒▒E3B!▒CN▒▒▒Ds!▒BCN▒ńE3B!!))▒’FȤ▒Ą▒▒▒b▒▒▒▒▒▒▒▒E3B!▒CN▒▒▒Ds!▒CCN▒▒▒E3B!▒CN▒▒▒D3B!▒CN▒▒▒D3B!▒CN▒▒▒E

but cannot connect with USB.

what’s wrong with my panda?

is there way to reset device to factory setting?

please help me :’(


#4

@ Gus -
Finally I fixed this problem. I did the following step!

  1. I turn to serial debug mode connecting MOD/GND pin
  2. Connect to device using USB 2 TTL module on COM1
  3. Press LDR0 and Reset button to turn GHI Loader Mode
  4. At this time, FEZ Config tools get no response
  5. Try to connect using tera term
  6. Type ‘V’ and return key
  7. Version text is shown
  8. Type ‘E’ and return key to erase user code
  9. Type ‘X’ and return key to upload firmware
  10. Selecte XModem menu in tera term and selecte send menu
  11. Checke 1K and select 4.3 Frimware.ghi file in Program Files\GHI Elec folder
  12. wait while firmware is uploaded
  13. Type ‘R’ to reload firmware
  14. Finally success to connect with USB!

This may help someone. Thanks!