Main Site Documentation

Panda II DOA


#1

I just bought 3 more Panda’s (great little rigs) but one seems to be DOA unless there is something else I could try. After a half dozen try’s I got into the bootloader through Tera Term but it will not load the new firmware. Xmodem 1k starts but never sends a byte. It gives me a serial number of 0, hardware version 10 and a not so cryptic message saying bad fimware but refuses to accept new firmware, even though it says it erased the bad one.

Any suggestions or do I return it?


#2

Just to to confirm, you did the exact steps with the other two FEZ Panda II and it worked with no problems. is this right?


#3

Thanks for the response.

Yes. I have six of them and this is the first one that refused to accept the new firmware. Tried it with usb and with an outboard power supply and it just hangs on the xmodem upload. It also takes multiple retries just to get it into serial mode.

Randy


#4

Why do you need to be in serial mode? Does it work over USB?

Please contact GHI directly for an RMA.


#5

I need serial to upload the firmware. It just gives an unknown device error when plugged in as usb.

Randy


#6

Update. I spent another hour trying to upload the firmware on my I3 quad windows 7 machine. I reinstalled everything, sdks, drivers, all updates for .net and nothing worked. It still hung on the xmodem 1K transfer.

I moved to one of my other Vista quad’s and everything worked perfectly and I now have 6 Panda’s upgraded to .5.1. They will run on the win7 c# ide but I cannot upgrade the firmware on that rig.

Any suggestions as to what I might try to get the same results with the Win 7 machine?

Randy


#7

I would sugggest using external power when trying to upgrade the firmware. Your USB port may or may not be able to supply enough current.


#8

I had a 9V 1 amp regulated power supply on the units. Like I said, I am fresh out of ideas.

Randy


#9

We will look into it further once we have it back. Like I said, please contact GHI directly for an RMA http://www.ghielectronics.com/contact/


#10

Thanks… but as I mentioned it works perfectly now that I have upgraded the firmware on my Vista quad so it won’t be coming back. I tried another unit on the Win 7 rig and it also hung on the xmodem transfer but worked great on Vista.

They both work fine on usb power from the ide in win7 but they will not upgrade on that unit.

These little guys are replacing desktops running $1500 dollar DAQ’s 24/7 in life test data runs. I will need another dozen of them once the pc boards are done. I only have one rig here running Win7 so I hope that this is not a Win7 problem because some of the units in the shop are running it.

Randy


#11

I could not update my new Panda II to latest firmware using TeraTerm and Win7 machine (Always froze on XModem transfer).

I had to use community program FEZPanel.exe and it worked like a charm.

So its a TeraTerm+Windows7 issue, not your Panda.


#12

Thank you!

I will check out FEZPanel.exe


#13

my Win7 32-bit SP1 works fine with Tera-Term. Are you using 64-bit?
Interested, because I may update to 64-bit.


#14

I’ve been using x64 Win7 and Win7SP1 machines since day dot with Fez, never seen this kind of issue. Don’t be afraid of x64


#15

I am using Win 7 64 bit. Tried everything imaginable and it would not upgrade (it did erase and make it useless) until I went back to 64 bit vista where it worked like it always did.

I have not had time to check out FEZpanel yet.

Are you using the Panda II?


#16

I have a panda II, a panda or 6, a pre-release panda, a Domino and a Cobra. None of which have ever had an issue on x64 Win7.

Did you move ports or do you always have a “preferred” one? Often I think certain ports behave differently (you’ll find motherboards often run multiple “hubs” across the range of ports they have) so trying the device on different ports might help

Obviously since you have 5 that behave one way and a 6th that doesn’t, that points to something more related to that one device than anything. Since Gus offered an RMA, might be worth sending it back and letting GHI decipher what might be going on.


#17

This thread has probably become a little scattered so I will recap. I bought 3 new Panda II units and when I tried to upgrade the firmware It would erase the firmware but would not, no matter what I did, upload new firmware through Tera Term. I had already upgraded three other units with Tera term and no problems but they had been done on one of my 64 bit Vista platforms. Things have been migrating to the Win7 unit (probably the 28 in monitor has something to do with that) but nothing would let me upgrade them with Win7.

Savvkin suggested FEZpanel and I downloaded and compiled that and it works perfectly on Win7 64 bit. It is also very simple and fast, kudos to Ravenlabs.

Tera Term still works on Vista 64 and does not work on my Win7 64 with any of my Panda II units.

Many thanks to Savvkin for the FEZPanel tip.


#18

So I think what you’re saying is that no matter what you did on your new Win7 x64 machine, you could not get ANY Fez to upgrade? That’s not quite what I thought, I thought very specifically that you had ONE out of the three that wouldn’t upgrade on the x64 machine (and that the others could).

So that changes the problem statement somewhat. Given that there’s a specific version of Tera Term on the GHI site that works with their bootloader, is it possible you installed a generic Tera Term from somewhere else ? Given that Fez Panel works from this x64 Win7 machine, it would seem that general comms to the board works as expected, so the Tera Term is the only thing that makes sense to me now…


#19

That is correct, but I was using the Tera Term downloaded from the GHI site. It will connect on the com channel, give a version number and erase the firmware but on xmodem send 1 k the box would come up and no bytes would transfer. After a few minutes the xmodem box would disappear and sometimes a message would say bad firmware, sometimes just a BL.

FEZPanel worked on the first crack. I had forgotten that I upgraded the original Panda’s on the Vista machine. The new Panda’s were running 5.0 and ran the code I am using for the life testers, but when I tried to uprgade the first one to 5.1 it would not go and my first assumption was that there was something wrong with the Panda II. That turned out to be incorrect.