Main Site Documentation

Panda II digital pins and power


#1

While running through a few tutorial / getting started I ran into a couple items with my Panda II:

  1. I am unable to blink the onboard LED as described in the getting started video. FEZ_Pin.Digital.LED doesn’t seem to be the right pin on the Panda II.
  2. I put together an LED on my breadboard driven via a transistor, and I initially connected the transistor to the D20 port on the Panda (right side set of pins, 2nd from the top on the left-hand column). FEZ_Pin.Digital however doesn’t have a D20 pin, nor does it have a Di20 pin. There’s not an “IO20” pin either (though there is an “IO21” pin). I connected the transistor to the D21 pin and tried FEZ_Pin.Digital.IO21, but that did not work. Connecting it to D0 and using FEZ_Pin.Digital.Di0 worked as expected.

As for powering the Panda and the other things on my breadboard (currently, a big pile of LEDs and a shift register), how much is it safe to draw from the “5V” port on the Panda? At what point should I start powering things from elsewhere?

Am I correct in assuming that I can power the Panda with the “Vin”/“GND” ports? Does that voltage need to be 3.3v or can it be 5v? How should I set this up, assuming the only power supply I have supplies either 5v or 3.3v, but not both at the same time, and my LEDs etc need 5v?


#2

Please Wait till we get the new SDK out in few days. FEZ Panda II is not fully supported with the current release.
FEZ_Panda_II.dll is not even there in the current release. I assume you are using FEZ Panda’s library and that will not work.

We only shipped few FEZ Panda II (As you notice FEZ Panda II is still under pre-order status) because we assume that the one getting it is familiar with FEZ in general and they can use it with the Beta SDK.

So please keep you FEZ Panda II aside for couple days till we officially launch this product along with the new GHI SDK then follow the steps to update the firmware then every thing will be smooth. :wink:


#3

This is not fair… problems and I haven’t even got mine yet…

Wait for me…

Cheers Ian


#4

Indeed I am using the Panda I library. It’s version 1.0.11, and that version matches my SDK as well as the firmware. I didn’t realize that the Panda II would have a different library.

Can I get a copy of the beta SDK?


#5

Not problems, just my impatience coupled with my inexperience :slight_smile:


#6

SDK will be online tomorrow, if not then we can just give you a link to the beta.


#7

Awesome, thanks, I’m beyond excited :slight_smile:


#8

As promised:

http://www.tinyclr.com/forum/15/2705/#/1/msg26633

Thanks GHI!


#9

I came here to post and I saw your post! I am no longer the fastest, Architect has new record on speed!


#10

Time to update! 8) Architect is faster then light :smiley:


#11

It was just a coincidence. :o


#12

Coincidence!! I think you carry this forum around with you…

Are you on android or iphone or steroids.

Cheers Ian