Oh oh - only one USB host port?

Fear not !! All you need is a cheap USB hub :grinning:

Plugged in

  • USB camera
  • USB card reader
  • USB mouse dongle
  • USB drive
  • USB Wi-Fi dongle


Do you know if it has support for those hubs with integrated ethernet?



@Mr_John_Smith - I do not have one of those to test. Also not sure how that HUB enumerates o the the OS. I will try to find one to test.

@ Designer

Done, ethernet usb supported: https://www.amazon.com/gp/product/B00M7MYFAU

We will have this in next release but if you want to play this on this weekend, just let us know.


@Dat_Tran - awesome.

I don’t have that product, but could try with a different USB to Ethernet device.

Any device with standard USB profile should work. I forgot the profile name.

I have a $4 dongle from EBay ready to test with the next release.

1 Like

We support “USB_RTL8152/RTL8152” or compatible with this chip. Not sure if it supports your dongle.

The one @Mr_John_Smith show us uses RTL815x so it works as we have tested it.

The $4+ adapter I bought has the right chip. I will test with the next release.

0.1.3 is out,
code is similar to wifi, just need to change NetworkInterfaceType.WiFi to NetworkInterfaceType.UsbEthernet

Networking (ghielectronics.com)


Is it possible to have both at the same time?

Not for now

WiFi and Ethernet work same time · Issue #70 · ghi-electronics/Endpoint-Libraries (github.com)

Checked out usb-ethernet on the new beta release using the $4.50 adapter I got on eBay. It worked.

I did see something funny. I suspect it is a Linux thing…

First I used the tutorial code, from the GHI site, for usb-ethernet. The tutorial uses a static IP address. After modifying the example to include the desired IP address and gateway address, I deployed and after a few seconds I received the link connect and ip address events. I was able to ping the device and also SSH into it. All was well.

I then changed the code to use DHCP. I commented out all the static address info and enabled DHCP. I then deployed. The device thought a while and then connected and received an IP address change event. But, instead of a DHCP issued address, it had the static address assigned in the first test.

I then refreshed the OS, and deployed again. This time I received a DHCP address and associated info.

I saw something similar with WiFi. I had connected to one of my WiFi networks, and then tried to connect to another one. The device connected to the first WiFI network, seemly ignoring the SSID in the WiFi connect.

The inexpensive usb-ethernet adapter connected at 100MB. I have order a 1GB usb-ethernet adapter on eBay to see how that works. I did have to spend $6.50 on the faster one.


Thanks for the details @Mike This will be helpful in covering any issues.

1 Like

Link? By the way, I bought couple WiFi $3.5 from your link before and they work so good, better than what we had before. Thks

This is the link to the faster ethernet adapter. It has the right chip. I should have it in a week and will verify that it works.


1 Like

Quick question, can Endpoint read from Raw Hid devices or just the usual keyboard/mouse?

If I understand you correctly then yes.

Endpoint-Libraries/Dotnet/GHIElectronics.Endpoint.Libraries/GHIElectronics.Endpoint.Devices.UsbHost/HidInput.cs at main · ghi-electronics/Endpoint-Libraries · GitHub