Main Site Documentation

Not able to communicate with FEZ Spider in visual studio 2012


#1

Hello, I recently bought a Fez Spider starter kit to try out .net Gadgeteer. I worked my way through a setup tutorial installing .net MF 4.3 SDK, netmf and Gadgeteer package 2013 R2 and the FEZ config. I updated the firmware to 4.2.11.0 and then created a new project in which when I press a button a LED should blink. However when I tried to debug the program I got a number of different errors/ warnings:

  1. Cannot find a schema that defines target namespace ‘http://schemas.microsoft.com/dsltools/GadgeteerDSL’, schema validation skipped.

  2. Device not found or cannot be opened - USB:EMX. (when I use FEZ Config to ping the device it does make a connection)

  3. in the output window:
    Assemblies successfully deployed to device.
    Restarting interpreter…
    Attaching to device…
    Waiting for device to initialize…
    The debugger engine failed to receive any debug events from the debugging target

After trying numerous times it worked for a couple of debug runs. (the code worked and the LED blinked once after I pushed the button: yeey!) Then I wanted to try out the T35 display so I disconnected the board but after hooking it up again I got the same kind of errors.

I’ve tried rebooting my pc, reinstalling everything and reupdating the firmware but nothing seems to help. I checked the GHI .net MF USB Debugging Interface driver in device manager and it shows as correctly installed.

Can anyone please help me resolve these issues?


#2

Hi Wouter, and welcome to the forum !!!

Yep, you’ll find lots of us here to help you get working.

First up, here’s the troubleshooting tips page https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting

My first guess is that you have a mismatched bootloader version and you need to resolve that. So what you would do to check that is to connect the Spider to your PC in normal mode, run MFDeploy, change to USB connection, and check “device capabilities” (if you can’t see the device at that point, then you have some other issue). Then if the bootloader version doesn’t match the version that came with the GHI SDK you installed (check the release notes from your PC to confirm), you will need to use the “legacy updater” from the support page https://www.ghielectronics.com/support/.net-micro-framework (see the last point on step 4).

Anyway, start with those checks and let us know where you get up to.


#3

Thanks for the really fast reply Brett! I looked at the version of the bootloader and indeed it was an old version (4.0.7 I believe) so I used the legacy updater to update to 4.2.11 After replugging the mainboard my pc had troubles recognizing the device. So I set the DIP switches to default and it seemed to recognize the mainboard again. However, after unplugging the device my pc crashed. I plugged in the modules I was working with and restarted my pc. It still recognized the device and didn’t crash anymore and it even debugged on the hardware! But only for a few times… Now it again gives the output of:

The debugger engine failed to receive any debug events from the debugging target

The warning of schema validation is also still present (even in the debug runs that worked). I must add that after I get the message of failing to receive any debug events I can click two or three times and the LED blinks but after that it just won’t work anymore.

Although I don’t think it has anything to do with not being able to debug I am going to try and find an external power plug because I think the crashing of my pc might have something to do with having to feed the board.

Any other thoughts on what might be wrong?


#4

Okay an update on the situation: I installed everything on a fresh windows 8 partition but it gives the same errors. I also plugged in a power pack but it doesn’t help either.

The problem has something to do with the debugger engine and I can distinguish two types of situations:

  1. ‘debugger engine cannot be attached!’ in which I think the debugger is just stuck because this happens after lots of tries to debug something.

  2. ‘The debugger engine failed to receive any debug events from the debugging target.’

Tbh I’m running out of ideas of what to do so any input is appreciated!


#5

By driver you mean the GHI .NET Micro Framework USB Debugging Interface?
Driver Version 1.0.0.2,
Driver Date 13-1-2010.

It looks a bit old to me but when I try to update the driver through the method mentioned windows says it’s up to date:
https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb


#6

can you please add a screen shot of the driver details page/s ?


#7

Sure, there you go. If I understand the documentation correctly there should be another driver (GHI_NETMF_Interface) which I never see pop up in the device manager. Updating the GHI .net Micro Framework USB Debugging Interface driver doesn’t work so maybe it’s the other driver?


#8

You’re definitely not using WinUSB, that’s what I would suggest you try.

https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb

Follow the instructions there, from the “Click on Update Driver” step.


#9

@ Wouter88 -

Not sure where you stand now but I will make a few suggestions.

I find that using winusb driver works best with VS2012. I have the Express version Windows for Desktop. See Cap1… (At least for my computer winusb works better)

I sometimes need to open the application properties and select Deployment Transport:
Serial first and then select Transport: USB. Device then shows Device: EMX_EMX

See for WinUSB
https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb


#10

Firstly thanks for all the replies, it keeps me going! I made screenshots of pretty much every step I took.

In VS2012 Express I almost always see the device. Only when it somehow gets stuck it isn’t visible but replugging the Spider solves that.

I can ping the device with FEZ config; .net MF deployment tool however doesn’t work anymore although it did this afternoon.

In the device manager I see the driver but it’s as I suspected an older version so I click update, browse to the folder in which the new updated version is located and immediately get prompted with the message that the driver is already up to date.

If I browse to the file in explorer and open it with notepad++ the driver version specified in the top section of the file is totally different.

I have no clue why windows doesn’t want to update the driver but is it maybe possible to manually switch the driver files?


#11

@ willgeorge -" I sometimes need to open the application properties and select Deployment Transport:
Serial first and then select Transport: USB. Device then shows Device: EMX_EMX"

I always need to do that as you did.
Why, is the bug of NETMF or GHI?


#12

@ andre.m nice find! I opened the ghi_netmf_winusb.inf in notepad++ and converted all the LF’s to CRLF’s and tried updating the driver again: it worked! Rebooted the pc and tried a few debugs but after a couple of debugs I got the same message in the Micro Framework Device Deployment Output window (see image). Is it possible that more files are broken atm or should I look for the problem in a different area?


#13

no, I use only VS, I always need to select Deployment Transport then VS can find the device,
or plug and unplug the USB many times, waste time always.


#14

My initial thoughts are that this is NOT a common issue and that there’s something different/special about your situation. I suspect that this issue has been seen by all of us once or twice, but it’s not every time we go to deploy. I however don’t know how you’d go about figuring out where the issue is; let me ask, do you rename your boards when you flash a new firmware onto them? The new project wizard tries to do something smart and set the connection to what it thinks your device should be/is called, perhaps that could be getting it confused?

If you want to discuss/investigate more, I think we should get a new thread going so we don’t detract from Wouter’s diagnostics too much


#15

Thank you Brett.