No Gadgeteer Template

I’m trying to install the .NET Gadgeteer but there is no Gadgeteer template.

I have installed all the components for Visual Studio 2013 Community, including the Gadgeteer Core as shown in the installation list. I have tried it again a few times.

I also have Visual Studio 2015 on my computer and wondered if this was the problem. I was hoping to use the patch and thought I would have to install Visual Studio Community 2013 first as netmfvs2013.vsi would not install without it.

I’d like to keep Visual Studio 2015 as I’ve got other stuff installed.

Help would be much appreciated.

you do need to step through all the items in .NET Micro Framework – GHI Electronics which means installing netmf SDK (step 2) before you install the vsix for the version you have, then install Gadgeteer SDK (step 3), and then installing GHI SDK. Did you do all those in that order?

I suspect not do I have to uninstall?

I missed the Gadgeteer one initially and then went back.

you can get away most times with uninstalling them to the point where you can reinstall them in the correct order - so if you installed netmf, then GHI then gadgeteer, you need to uninstall gadgeteer then GHI, then reinstall gadgeteer then GHI… Do that as far back as you think you may have got out of order - I’d say just do the scenario I just typed, and see :slight_smile:

Thanks Brett all working in terms of software. I’ll try and patch 2015 later.

1 Like

@ shapingstuff - Hi, I have the same problem too,I have only .NET Gadgeteer Application and I went through the process step by step.
Can’t I add the templates manually now?

I don’t think so because you need the other Gadgeteer stuff. I had to go back to before the gadgeteer SDK install and that did the trick, never took too long thankfully.

@ shapingstuff - It’s strange, I did it three times now and I only see one template.
Did you see other templates on vs2013 ?

There should be a gadgeteer tab and one template. It can be frustrating to install. Did you do both parts of the .net microframework install?

you mean

  1. MicroFrameworkSDK.MSI
  2. netmfvs2013.vsix

So yeah.

I’m not sure I can be much more help I’m afraid. I went back and reinstalled a couple of times.

@ shapingstuff - Here is your solution:

go for:


Application .NET Gadgeteer Builder Templates

Actually those templates are if you are building a Module or Mainboard (with the intent of providing these to other users). You don’t need them for creating a Gadgeteer application as an end-user.

Hi All,

Well, I’ve installed and uninstalled and resinstalled at least three times, and I still don’t see Gadgeteer when I do File… New Project…

I started with Visual Studio 2015, which didn’t work, then I noticed the note in the install page about 2015 not working properly. So I uninstalled it and installed 2013. I installed all the netmf bits in the correct order, or so I thought. Still didn’t work. Found this forum post which suggested uninstalling and reinstalling. Did that, then realised I’d missed a step. Uninstalled everything again (except Visual Studio 2013), and reinstalled again, taking particular care that everything was installed in the correct order. Still didn’t work. Did it again. Still didn’t work. Did it again…

Still no Netmf project type when I do File New project.

What am I doing wrong? Do I need to uninstall visual studio 2013? reboot my PC?

I started doing this at 2pm this afternoon. It’s now past 11pm. I’m ready to throw my PC out the window. But I can’t. I’ve bought three Gadgeteer boards and loads of modules (admittedly some years ago…), and I’d like to be able to program them. On top of that I have to do it in Windows 10, which is about 10 times slower than Linux MInt, which is what I use 90% of the time. I would love a version of Gadgeteer that runs under MonoDevelop (.net for linux) but that doesn’t appear to be possible. Maybe I should just buy an Arduino… No, wait, I’ve already done that. At least the IDE runs on Linux. Not as powerful or user friendly as Visual Studio, but at least I can get it to work.

I’ll get off my soapbox now.

All advice gratefully received,

Hi rcplaneguy,

the fundamental step here for netmf project types to appear is the second installation point in Step 2 from the GHI page. You have to not only install the netmf core SDK, but the integration components relevant to the version of Visual Studio you are running.

[ul]Install MicroFrameworkSDK.MSI
Install netmfvs2013.vsix[/ul]

By doing that, you should be able to open VS2013, and see netmf project types. Please run the VSIX and then reopen VS2013, and capture a screenshot of the new project page you see.

Hi Brett,
Thanks, that did it. I had assumed that installing the Framework SDK MSI from the unzipped directory would install everything in the directory, if you see what I mean, and that the comment about the vsix was just that, information. Didn’t realise I had to manually install that too. But all good now, and thank you for your prompt and helpful reply.
:wink: Ian

no, that’s why Step 2 clearly says:
Download Microsoft .NET Micro Framework 4.3 (QFE2) and unzip the file. Open the file’s folder and:

  • Install MicroFrameworkSDK.MSI
  • Install netmfvs2013.vsix

Great to know you’re working