Main Site Documentation

Newly received device not working


#21

This doesn’t make sense as you do not need any adaptor to update the FEZ firmware.


#22

which is why I think the COM port mixup is happening, and we need to go back to basic steps how to connect and what port is what, and slowly and methodically work through the steps.


#23

Hi Brett,

I tried one after the other. First the USB to serial adapter. And because this didn’t work I used a RS232 cable straigt to the computer.

regards,
Aart


#24

Hi Gus,

I have exactly followed the instruction https://docs.ghielectronics.com/hardware/components/spwf04sa.html. It stated:

Erase the Host Firmware

Before updating the Wi-Fi module firmware, you must erase the firmware on the host board or SoM. This is accomplished using terminal software while the board is in bootloader mode. The instructions are very similar to the instructions for manually loading firmware.

  1. Connect the board to your computer’s USB port.
  2. Put your board in bootloader mode. Each product has a specific way to enter the boot loader.
  3. Open any terminal software, for example Tera Term.
  4. Select serial and pick the COM port associated with your board (if unsure, check Device Manager).
  5. Press E and then enter to start the erasing procedure.
  6. Press Y to confirm, then enter.

I will try again on another computer…

Regards,
Aart


#25

Hi,

I have repeated the steps on a Windows 10 with USB->Serial adapter.

After plugging in the standaard USB one COM4 appears in device manager as GHI Bootloader.
If plug in the USB->Serial adapter a COM5 port appears.

If I use the ST Flash demonstrator on COM4 I get unrecognized device. If I select COM5 then the erlier mentioned alert appears.

If I remove the USB->Serial adapter and use a RS232 cable on port COM1 then the same error message appears.

Regerads,
Aart


#26

Hi Brett,

On one computer COM4 =GHI Bootloader and COM5=Profilic USB->Serial adapter. I used COM5 with ST Flash demonstrator and then the earlier mentioned alert appears.

Regards,
Aart


#27

Sorry, i realized you were right. But I also tried the COM port associated with the usb->serial adapter and also tried a direct rs232 cable. Both with same error message.


#28

Hi Dat_Tran,

I have not connected GND because that was not needed when the USB for power. May be it is needed when using a direct cable. I will test this later. I have also used to short RX and TX to test COM port. It was COM2 with direct cable. I will later test with USB->serial adapter!

Thanks for your suggestions!

Best regards,
Aart


#29

I have also tried to short RX and TX of the USB->Serial adapter and Terra terminal echoes the characters as expected. This on a windows 10 computer. Also tried to use ST flash demonstrator but same error message!

I think the WiFi can’t go in Boot mode and may be defect!

Best Regards,
Aart


#30

The RS232 Output of a PC exposes too high voltages (may be more than 5 V). If you connected an RS232 port to the WiFi Module you might have killed it.


#31

Hi RoSchmi,

Ok than I have probably killed it. But if I reload the FEZ firmware the LED around the WiFi module start flashing again. I have also another board (i bought two) so I think I will return the bords to Mouser. Without the direct RS232 it also didn’t work.

I have spent enough time with this board. I think I will search another board or come back when the this WiFi problems are solved!

Thanks for your support!

Best regards,
Aart


#32

BTW if I reload the FEZ firmware then after: wifi.TurnOn(); the led starts fashing. fast flashing a green LED, slow flashing a red LED and not flahing an orange LED. I don’t what this mean but it is the same when the board was new.

Do you still think WiFi module is killed?

Strange thing is that on on computer these LED’s starts flashing without direct after flashing the firmware and on other computer not. It hangs again on JoinNetwork. WiFi has never worked and I can’t get it working in an easy way.


#33

my opinion, based on no experience, is that the wifi module is probably ok (but please don’t use the RS232 cables in bare format again)

I’d now suggest that the USB to serial you’re using is not working on 3v3 logic levels successfully. If you’re willing to work thru it I’d find another USB-to-serial adapter that had 3v3 onboard, as that usually means they will work. I have a few of the CP2102 boards like this one https://www.ebay.com.au/itm/3-3V-5V-Power-Black-USB-2-0-To-TTL-UART-6PIN-Serial-Converter-CP2102-Module/302629484655 that I regularly use on the older generation GHI boards and always get 3v3 serial comms working fine. In fact, an easy way to test if your current one works is to write a serial port program on tinyclr and connect that and confirm that you can send/receive over it.


#34

Hi Brett,

I have measured the voltage on the TX and RX of the USB->serial adapter and it read 3,8V and 3.3V. This was when the adapter was not in use and I suppose these line are high when not in use. Bus as far as you know is this adapter 5V ?

Further the adapter was tested with Terra terminal by shorting RX and TX. It echoes the characters so in principle it is OK. Do you have a tinyClr or .net example to test the USB->serial port? May this can shorten the test.

It became much effort to make a new board working. This board has no use for me when wifi is not available or works unreliable.

Best regards,
Aart


#35

BTW Brett, It is Prolific cable and it is 3,3V (https://www.kiwi-electronics.nl/usb-to-ttl-serial-kabel). It is also used with Arduino. I am now out of options!


#36

the link you sent us shows that device only presenting a 5v wire - usually a sign that it doesn’t operate at a 3v3 logic level, but those voltages that you see present may not line up with that. Fundamentally, the wifi module on the Fez board is operating at 3v3, and the usb-serial needs to work at that level to be able to communicate to this.

I just took another look at the firmware update instructions, and there’s a comment there that might help us.

When the Wi-Fi module starts, it sends a PowerOn message which tells you what firmware version is installed. For example, PowerOn 171117-0328fe3-SPWF04S . In this case the firmware is dated 17 November 2017.

So if you have the board set up with the usb-to-serial connected to the Wifi module, and you have teraterm connected to that serial port, and you then re-power the device (plug in the other USB cable) it should spit out the above power on message and you should be able to see it - swap TX/RX if you can’t, and try powering it up again


#37

Hi Brett,

I have done what you suggested but teraterm gives no PowerOn message. Even swapped TX/RX (i am pretty sure that these were correct connected) but also no PowerOn message was received. The used USB to Serial cable has 5V 500mA power over the red wire. It also stated that it had 3,3V on RX an TX as used with Arduino’s. The red power wire is not even connected as per GDI instructions. I have even tried the brand new second board (i ordered 2 at Mouser) but it gives the exact same result. Problem is that connecting H1 (BOOT0) to 3,3V doesn’t bring the WiFi module in boot / terminal mode. May be this is because I got boards with an old WiFi hardware). I am not sure what to do next (except for asking a RMA at Mouser).

Thanks for your continued support!

Best Regards,
Aart


#38

sorry BOOT0 being connected should put the wifi into bootloader mode, and that message likely comes only when in normal-boot mode. Can you try without connecting it and see if that spews out the status info (or any info?) Cycle BAUD rates along as well, to see if it gets any data out.

If anyone else playing along here at home also has a FEZ wifi board and can test this to prove it does/doesn’t work, that would be great? (And GHI, if you want to send me one for “training” purposes :wink: )


#39

Hi, I would give the board one more chance doing it the way I used. Download the little programm I made to set the board in a defined condition.


Deploy and start this program. When you are asked to press the button (output window) --> press BTN1. Now your board is in a defined defined condition for updating the Wifi
Module. Repower the board and disconnect it again. Then apply the 4 cables as can be seen on the picture on my repo. Then plug in the 2 USB connectors. Open STMFlashLoaderDemo and select the proper COM port and 115200 baud rate. Press BTN1, then click Next. When it doesn’t connect pull the USB connector of the FEZ board and push it in again. Then click Next again and you should go.

Edit: Forgot one step (second press BTN1), is included now.


#40

Hi RoSchmi,

Thank you again!

I have downloaded your project! BTW I think you didn’t forgot the seconf persse on BTN1 because I see WaitForButton only once.

I will try in a second!

Regards,
Aart