Main Site Documentation

Newbie here, having problems with Chipworkx device


#1

Updated tiny booter and firmware to 4.1.5.1…since then not able to deploy any kind of code to the device. I always get an error ‘Check your hardware’.


#2

You need to update your assemblies on your project…remove them then add them back


#3

Still no luck…Do I need to update my Microsoft .NET MF version as well?

Here is the code, if it is of any value: Also as you can see I am not using any GHI references

using System;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Hardware;




namespace MFConsoleApplication1
{
    public class Program
    {
        public static void Main()
        {
            
            Bitmap bmp = new Bitmap(480, 272);
            Font myFont = Resources.GetFont(Resources.FontResources.NinaB);
            bmp.DrawText("Amazing Innovation on the way !!!", myFont, Microsoft.SPOT.Presentation.Media.Color.White, 0, 0);
            //Bitmap photo = Resources.GetBitmap(Resources.BitmapResources.football_game_001);
 
            bmp.Flush();
        
            
        }

    }

}

#4

try starting a new project, it worked for me


#5

Here’s teh way I always consider testing this.

Create a new project, using the correct template project for your device. Then deploy. If that fails, it’s something outside your project and keep digging. If it works fine, then the issue is your project - as Gus said, you have to rip-and-replace references in your project as the project holds the old references.