Main Site Documentation

Newb needs help with FEZ Spider kit


#1

Hi there,

Just received my FEZ Spider kit and pretty much went through all the necessary steps to update my firmware. I am pretty sure it worked, these are the results I get from the FEZ Config tool:

Connecting to device…EMX_EMX
Loader (TinyBooter) Version: 4.2.10.0
Firmware (TinyCLR) Version: 4.2.10.1

I have VS2010, I installed the 4.2 framework QFE2
installed all the latest SDK software from GHI.

I see the following in the device manager when I connect the device:
GHI .NET Microframework USB Debugging Interface

I am able to ping the device and am able to run the emulator console app. I had a small hiccup when I tried the hardware console app, it mentioned that the Hardware assembly was missing and the PKCSII assembly as well. I added them and it worked.

Now for the actual issue…when I try to execute the First Gadgeteer project (the one with the camera) visual studio keeps giving me the following error when I attempt to deploy:

Error 1 Device not found or cannot be opened - USB:Gadgeteer

I saw in the 4.2 read me notes that it mentioned this behaviour might occur so I attempted to redeploy and no luck…I have uninstalled and re-installed everything multiple times.

Here is the Device Capabilities from MFDeploy:

HalSystemInfo.halVersion: 4.2.0.0
HalSystemInfo.halVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
HalSystemInfo.moduleSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
HalSystemInfo.systemSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
ClrInfo.clrVersion: 4.2.0.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.2.0.0
SolutionReleaseInfo.solutionVersion: 4.2.10.1
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: May 1 2013
SoftwareVersion.CompilerVersion: 410713
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 320
LCD.Height: 240
LCD.BitsPerPixel: 16
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

Please help : - )


#2

Hi there Magnuskeel, and welcome to the forum !

I think all you’re seeing is that the default Gadgeteer application tries to use a device name of Gadgeteer, and your device is not named that. So if you go to Solution Explorer (right side panels) right click on the project and select Properties, then go to the last tab “.Net Micro Framework”, change the transport to “Serial” and then back to “USB”, and it should detect your device correctly and fill in the right name. Then, you can close the properties page and hit F5 to try the deployment again. Good luck !


#3

thanks for welcome…and acutally it was my bad…after all that digging it turns out my startup object in visual studio was not set to GadgeteerApp1.Program…as soon as I selected that it worked right away…sorry about that