Main Site Documentation

New SDK Error


#1

Downloaded the new SDK and was able to update my G400 firmware just find. Now I can not get Visual Studio to deploy firmware to the device. FEZ config connects and see the G400 just fine but nothing from Visual Studio. Any ideas?

Thanks

Todd


#2

@ tstewart - Sorry to hear you are having troubles. Would you please be able to provide us with a little more information about your environment? What version of VS are you running on what OS?


#3

Visual Studio 2012
Windows 8.1 64 bit.

Connecting with Visual Studio before the upgrade worked just fine. Now after upgrading to the new SDK Visual Studio will not connect to unit to deploy the application.

Todd


#4

@ tstewart -

G400 requires to update all new Bootloader, TinyBooter, Firmware from 4.2.11.1 to 4.2.11.2, not only firmware. Did you do that?


#5

Quote from first message “Downloaded the new SDK and was able to update my G400 firmware just fine.”.

Yes the firmware and TinyBooter are updated. That worked just fine. It also has been verified with FezConfig to make sure the update was done correclty. FexConfig still connects just fine and ping works. The only problem is deployment from Visual Studio.

Todd


#6

OK the TinyBooter is version 4.2.11.1. I was wrong, the version I was looking at I thought it was TinyBooter but it wasn’t. So now to the next problem.

I have followed the steps for updating the TinyBooter but I am getting the following error when running the ProgramG400.bat,


#7

@ tstewart - This happen when serial driver is busy. Close FEZ Config disconnect usb from g400 and plug again with pa11 closed to gnd and retry operation. Don’t open fex config until finished tinybooter flashing.


#8

@ dobova - That may have been the issue. I was able to get the TinyBooter updated today.

It still not solve the problem of Visual Studio not being able to deploy the app though. Here is the output from Visual Studio

Looking for a device on transport 'USB’
Starting device deployment…
Iteration 0
Iteration 1
Iteration 2
Iteration 3
Iteration 4
Iteration 5
Iteration 6
Iteration 7
Iteration 8
Iteration 9
Iteration 10
Iteration 11
Iteration 12
Iteration 13
Iteration 14
Iteration 15
Iteration 16
Iteration 17
Iteration 18
Iteration 19
Iteration 20
Iteration 21
Iteration 22
Iteration 23
Iteration 24
Iteration 25
Iteration 26
Iteration 27
Iteration 28
Iteration 29
Iteration 30
Iteration 31
Iteration 32
Iteration 33
Iteration 34
Iteration 35
Iteration 36
Iteration 37
Iteration 38
Iteration 39
Iteration 40
Iteration 41
Iteration 42
Iteration 43
Iteration 44
Iteration 45
Iteration 46
Iteration 47
Iteration 48
Iteration 49
Iteration 50
Iteration 51
Iteration 52
Iteration 53
Iteration 54
Iteration 55
Iteration 56
Iteration 57
Iteration 58
Iteration 59

It acts like it can not find the G400. Here is the screenshot from the device manager.


#9

@ tstewart - ok, Now you have g400 in tinybooter. Have you flashed firmware after tinybooter using fezconfig?


#10

The firmware had already been updated. The first time I did not realize it was a two step process. I did a project over a year ago with ChipworkX and did not remember it being two steps and did not have any real issues getting that project working.

I went ahead and reprogrammed the firmware and got it to final deploy the app. Now still getting the same issue that this firmware was suppose to resolve. “Failed to perform I2C transaction”


#11

Bugger this got me too, might want to include it in the instructions at https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400