New Raptor stuck

After several attempts, I got to load a couple of lines of code onto the board exactly once and that was it.

The board no longer appears as a USB device, and shows up as a COM port instead (Bossa Program Port).
FEZ Config doesn’t detect it either in USB or Serial mode, and does not recognize the board either.
Attempting to update the G400 bootloader aborts with the error:

-E- Script File Bootloader.tcl returned error : Error Initializing DataFlash Applet (Can’t detect known device)…

Suggestions are welcome.


I know it’s not much help, but I came across this exact same error on one of my boards. I had to set it aside and move on to a different one, because, like you, I couldn’t find a way to get it to run.

@ mcossi - Are you running UpdateLoader from a CMD.EXE window that has been opened with Administrative privileges?
Then entering the COM port number when prompted? The COM port number is shown in Device Manager.

UpdateLoader.BAT is located in \Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\G400.

Also from this link you need to hold pin 9 of socket 3 to ground for three seconds during power up. Then disconnect from ground.

The above link also has a new bootloader, you may wish to try at some point.

@ PHITEK - I tried the elevated command prompt, with exactly the same results.
I also tried different pins - some say that you need to ground pin 8, others pin 9. Neither worked, but if I understand correctly that’s just to put the device in programming mode and I’m already there. According to some documentation, removing power should put the board back to normal (i.e. exposing an USB port), but that’s not happening.

@ Iggmoe - I guessed I’m in the same boat. I ordered a new Raptor to complete the project, but I would still like to get this one to work if there’s any way to do that.

@ mcossi - I had a similar issue when executing the script on WIN10. Fortunately, I have my work laptop that is still running Windows 8.1. The bat file was able to update the board successfully.

I had a similar issue trying to load from the BAT file and found that it was because I had Fezconfig open. Make sure that and or VS is closed before you try to run the BAT file.

I have the same error; The board shows in my PC (Windows 10) as COM (not as usb device) and I can’t run a program on it (bootloader is flashable). Tried all the mentioned solutions from this thread but nothing did help. FEZ Config can’t flash firmware.

Okey, I got it working now by using the 2015 SDK:
[ul]Flash tinybooter from the firmware folder
Flash firmware via FEZ Config
Install 2016 SDK
Use bootloader installer
Update Raptor using FEZ Config[/ul]

1 Like

@ mcossi - I’ve seen similar issues as well, and while I can’t be certain of it, I can definitely say that I’ve had issues with boards on a USB 3.0 port, and by going into the bios of my laptop, and forcing it into 2.0 mode ONLY, the issues have decreased. Just a suggestion.