New Raptor, New Project, doesn't load or run anything

I just got a new FEZ Raptor board last Friday. I spent some time this weekend with it. It doesn’t load the program code from VS. I start it up in Debug mode and I get the following:
Looking for a device on transport 'USB’
Starting device deployment…
Iteration 0
Iteration 1
All the way to Iteration 59 then it fails with Error 1 Device not found or cannot be opened - USB:Gadgeteer

I’ve tried this with modules attached and with no modules except the USB Client DP module. Yes, both LED’s (Red) on the USB board and the Raptor are on.

I’ve tried it with a program that doesn’t do anything except have Debug.Print(“Program Started”); in ProgramStarted() along with some code to initialize the modules.

I’m running Windows 7, SP1 with all patches and updates installed. I’m running VS 2013 Ultimate with the latest and greatest Updates installed. I’ve also tried running it in VS 2015 and no luck. I’ve started it in Debug mode and without Debugging started. I’ve Deployed the code (on the VS Build menu), along with starting using Step Into and Step Over.

Yes, I do see the board in Device Manager. Yes, I have Firmware 4.3.8. Yes, I have 4.3.6 of the Loader installed. I’ve installed, removed and reinstalled and repaired the following:
Microsoft .NET Micro Framework 4.3 (QFE2)
Install MicroFrameworkSDK.MSI
Install netmfvs2013.vsix
Microsoft .NET Gadgeteer Core
GHI Electronics NETMF SDK 2016 R1 Pre-Release 1
and also tried
GHI Electronics NETMF SDK 2015 R1

I’ve used 2 USB 2 and 2 USB 3 connections. I’ve also tried a separate computer with USB 2 only. Al I get is the above error.

Anyone have any ideas what’s going on?

under the project properties, change the interface to serial instead of USB and then change it back to USB. This sometimes refreshes the USB interface and helps.

Another thing to check is power. Try a powered hub or connect a power adapter to your board please.

OK, changing the device worked. Not I get a low frequency error. I disconnected the Hub and the error went away. I have power supplies on order and I should have them by Wednesday. Or is there a problem with the Hub?

A more visual description of the error might help (screen shot or similar). Can’t say I’m familiar with that error.

Can you also confirm you ran FezConfig and checked the bootloader and firmware matched your SDK installed version?

Yes, see above, I ran Fez Config, I have Firmware 4.3.8 and I have 4.3.6 of the Loader installed. The low frequency error went away at some point. I don’t know what or why, just that I hooked the hub back up and it works fine now.