New laptop struggles to deploy

I recently got a new laptop from HP, but it has struggles deploying software to our SC20100S based modules.

Programming firmware though the tinyclr config works just fine, but when deploying an app with visual studio, it fails almost every single time. The exact fault differs. Sometimes it only flashes half of the sectors, leading to an a30000 error at startup. Sometimes it flashes completely, reboots the module and hangs for a minute and then visual studio crashes.

There is nothing wrong with the VS project. It works on all other computers we’ve tried. The boards are also fine because my colleages have no issue programming these exact boards with their machines. All the boards are externally powered by a 24V DC power supply so I don’t think USB power output is at fault here either.

I’ve tried updating windows and updating all the drivers. This also does not solve the problem.
I have tried deleting the device in device manager and then replugging the board, also does not fix it.

The only thing I have found that seems to fix it somewhat, is to force windows to use the win8 USB driver that can be downloaded from the ghi site. However, this works once or twice before the old issue comes back.

Is there a way to enable verbose logging or anything else so that I can provide you with a detailed log from the TinyCLR visual studio extension?

Is VS community, Enterprise or Professional?

Community 2022, we are running this one on all of our machines.

You are one of our experts, I don’t think we need to ask you more questions.

I am waiting for other people’s suggestions :slight_smile:

There is no log files I can collect that would provide any insight? To me it seems like a driver error of some sort.

No, what window OS please? Win10 or Win11 no need special driver for USB.
Are you using QSPI as external deployment?

Latest update of W11.
External deployment is not enabled on these boards.

Is there anything in the Event Viewer? Right after you hit an error, run eventvwr and look in the System, Application, and Security folders for any errors or warnings related to VS or USB. There might also be driver related folders, but I don’t recall and I am currently on a Mac.

Visual Studio also emits a log file and you can find more info about that here : Use the Activity Log to debug and add entries - Visual Studio (Windows) | Microsoft Learn

I don’t have any recommendations for a fix, but digging into those log files may provide more actionable information.

1 Like

Just throwing stuff against the wall. Is there a difference between the various computers in regards to USB 2 and USB 3?

Is it I9 or I7 please? and yes, the USB port is 2 or 3?

If the laptop has a Ryzen processor, I have had some bad experiences with mobile and early AMD Ryzen USB controllers, especially with debuggers, VCP’s and things that require tight command timing & clock signals. What sometimes helped for me was using a powered USB 2.0 hub (that uses its own, usually Realtek or Cirrus Logic, controller IC). The issue does not seem to affect controllers from other brands than AMD.

Thank you all for your help. I reinstalled my laptop from a clean windows 10 ISO and now it seems to work just fine. Im not sure what the issue was. It is an intel i7 with a USB3 port anyways. Might’ve been some HP related bloatware…

I’ll test more over the coming days and will report back if I find any issue.


The issue is back, but it might be in a different form.

It seems like hitting deploy in visual studio activates the action twice. My output window is showing information about the device deployment DLLs, switches to writing sectors, then halfway thorugh switches back to device deployment DLLs and then back to writing sectors (which skips halfs the sectors this time). Most of the time, this results in a failed deployment with a crashed visual studio instance. Sometimes, deployment starts but the code executes much slower than usual. Using a breakpoint and every line of code takes between 1s and 5s…

Any reason the action is activated double?