Main Site Documentation

Network debug and deploy


#1

Can someone please explain me the steps to be able to debug and deploy over ethernet?
I searched the forum, but can’t seem to find anything.

Thanks


#2

You have to set it through GHIElectronics.NETMF.Hardware.Configuration.Debuginterface…


#3

Can someone, that has this working, post a code example? I still not managed to get it working.
What I’m looking for is to deploy new apps (and eventually debug) over ethernet to the Cobra.

Thanks


#4

What exactly is the problem? I assume you already used networking and you know how to set the IP address…etc through MFDeploy.
You just have to call the function and set Ethernet for TinyCLR debugging and USB for TinyBooter.
Reset the device and you are in Ethernet mode!
Try static IP first.


#5

Maybe I have “the concept” wrongly in my head, but what I’m trying to accomplish is the following:

My cobra will only be connected with ethernet (and power ofcourse), and I would like to continue development over time, adding features etc. So basically, I would like to deploy (by pressing F5 in VS2010) over ethernet “without” touching the Cobra physically. Is that possible? My Cobra will be 30 meter away from my pc.

I’ve set the IP address etc with MFDeploy


#6

Never mind, got it working :smiley:


#7

Eric, why not update your Cobra with IFU?


#8

Chris,

how does that differ from what Mike proposed? What steps are involved?


#9

IFU would be a pull scenario rather than a push.

The Cobra has to specifically PULL an update request from, for example, a webserver. This is useful for production scenarios when debug cannot be used to load FW/managed code. IFU can also update firmware without getting into bootloader mode.

Debug actually PUSHES the program to the Cobra.


#10

Thanks Chris for the explanation. I’ll stick with the method I have working for the moment, it suits my needs. One day I’ll look into IFU…


#11

I also need to use debug/deploy via ethernet, and tried to follow Mike’s instructions (since I’ve not really found other anywhere), but lost contact with the device.

I executed
GHIElectronics.NETMF.Hardware.Configuration.DebugInterface.Set(
Configuration.DebugInterface.Port.Sockets1,
Configuration.DebugInterface.Port.USB1);
return;

And then went to MFDeploy, which can not find the device, either by USB or TCP/IP. VS C#2010 can find a device “192.168.1.200 - (00-1a-f1-00-42-0d)”, but it cant deploy to it error “Device not found or cannot be opened - TCP/IP:192.168.1.200:26000”, and VS will not find it by usb either.

Anyone with suggestions on how to progress? Ideally via tcp/ip, but usb would be fine for now.


#12

Probably it is blocked by a firewall on your PC. Check firewall settings.
If you want to revert back to USB, you have to erase your application and download the firmware through MFDeploy to erase the old settings.


#13

Hi Mike,
You were right about firewall settings blocking mfdeploy - thanks. When I select tcp/ip it now displays “192.168.1.200 - (00-1a-f1-00-42-0d)” like VS2010.

But I still can’t ping, connect, configure or anything.

How do I erase and update firmware, when I can’t connect to the device?


#14

See the downloads page for instructions on erasing FEZ Cobra and downloading the firmware. There is a video too.


#15

http://www.youtube.com/watch?v=Y4Va_tPqqpg