NETMF porting to custom board


There are 3 versions available that are not free, MDK-Professional, MDK-Standard and MDK-Cortex-M. Would the standard be more than enough as I don’t see the need for the middleware libraries as I don’t see me using this for anything else.

Can it be built with GCC as the website states that only Keil MDK is supported? I assume a fair bit of work is needed to get it to compile under GCC?

OUCH… Having just received the prices for the full MDK that is not going to be an option at this time. The Professional version is way higher than even my copy of Altium Designer cost me! :’(

Okay, unable to get a build cranking for the disco board with version 4.3.

What I have:
netmf SDK 4.3 (SDK-QFE2)
PK v4.3 - This includes the regular MicroFramework_v4_3 folder + community-ports-master(jaydcarlson) + NETMF4.3_Community_master
I have arm-gcc compilers version 4.6.2 and 4.8.4.

I have tried to combine these porting kit folders in various ways. Out of all combinations, I have not been able to build the Discovery4 solution that originally resided exclusively in NETMF4.3_Community_master. I have been able to build the FEZCerberus solution using gcc 4.8.4 by just using the community-ports-master but I have not been able to communicate with the bootloader once I download it to the disco board. I did get the Cerberus solution working at one stage with gcc last week but alas, I have forgotten how (last week was a blur). I have been following tutorials from 2yrs ago ( so I suspect that the repositories that I am downloading have changed since then.

What set up will i require (links to the correct repositories would be helpful)? Will different versions of the SDK affect how the solutions are built etc?

Ideally, I would like to build a working discovery board solution for 4.3 that can be modified according to Justin’s instructions at the start of the thread.

Any help is greatly appreciated as what I’m doing now atm is becoming tedious


EDIT: I know it says for porting kit 4.2 but do I need to merge the NETMF_for_STM32 repo??

Okay, got FEZcerberus building with 4.3 and flashed it to the discovery. I am just working on modifying this code to allow it to run on my companies custom board


@ richoxski - well done - keep up posted on your journey.

The more people building firmware the more successful things will be :slight_smile:

@ Justin - Cheers :), But I have to wait until the custom board works before I celebrate (it’s requires hooking up an oscilloscope to see why it’s not flashing properly) ???. Last question, PK 4.3 + community-ports(jaydcarlson) [em]should[/em] be compatible with VS2013, correct?

Yes it should work in VS2013.

If you want someone to look over your design if its not commercially sensitive you could post it here or flick me a PM and i would happily look at it.

1 Like

The custom board is not working because the debugger or debugging utility that we are using is not flashing the hardware properly. The bootloader hex file that comes up is blank. The same hex file flashes alright to the disco board (the bootloader is recognised). I appreciate the offer Justin and it’s tempting, but I am not able to post any information regarding this piece of hardware.

I figured that the porting kit plus the community ports should work for VS2013 (I’m using professional) but I am getting a mismatch in the version of mscorlib between VS and netmf on the board. I’m wondering do I require an earlier release of the SDK? The only thing I can think of is community ports is compatible with an earlier release of the SDK (4.3 beta).

Does the board show up in MFDeploy?

Yes I can see the Cerb bootloader come up in MFDeploy. I then flash the CLR and I can also ping the CLR. I can even see the cerb bootloader from within visual studio. If I try to flash the board, the version of mscorlib between VS and the CLR on the discovery board(holding the FEZCerberus CLR) is seen as different.

Are you targeting the the correct framework in VS?

Says .NET Micro framework 4.3, notice the error displayed in the error list

I have referred to a couple of links and I am thinking I may have to downgrade my version of the SDK?

@ richoxski - you can not mix versions, or downgrade your sdk or upgrade the references with the lower version. but not both, it is an exclusive or.

1 Like

@ .Peter. - Well, I installed the lower version of the SDK (4.3 beta) and did not get any joy from it. When it says downgrade SDK are we going down by releases or by full versions? I would rather try upgrading the build to use the latest version of mscorlib. All i did was use the latest release of porting kit version 4.3 and mixed it with ghi community ports. Apparently this should have worked with SDK 4.3.

For 4.3 i use QFE1
For 4.4 i use RTM

Both happily co exist without issue.

Just to clarify. NETMF 4.3 RTM (QFE1)?

@ richoxski - yup

1 Like

1 Like