Main Site Documentation

NETMF Framework in VS2010 missing?


#1

I’ve installed .NET MF 4.1 and the templates etc are installed correctly in VS2010 however when I go to add reference and select the framework no MS assembly are listed. Anyone seen this before?


#2

is that in a brand new project, or an existing one? I’d seen similar with an old project, but not when I created a new project (and I couldn’t seem to repro it either on other projects). If you create a new project (say a Cobra windows project) you should get a handful of MS references added in, then try adding another reference and you should see them.

The only other thing I’d suggest might be to try uninstalling GHI and netmf SDKs and reinstall in the correct order, making sure before progressing that you can see the references at each point.


#3

Just to be sure: You must install both the Microsoft NETMF SDK and the GHI 4.1 SDK.


#4

What sort of project are you doing…

Exsisting or new… The reason I ask is on the New Project wizard if you dont select micro.net as your base… you won’t see any .net references…

Also… if you select Project…add reference… from the top menu you also don’t see any…

If you right click on references in the right window (solution explorer )

and select add reference they are all there

I also found this wierd… (once you’ve clicked on the solution window, ie focused on it, then you can select .net references from the pull down menu )

I hope this helps

Ian


#5

Do you happen to have Productivity Power Tools plug-in installed? If so, disable it to get back the normal references dialog.


#6

Yes I do have the power tools though I don’t really want to disable it :frowning:

I can manually add the ref’s from the Assemblies/le folder in the NETMF install so not a huge bane just curious why they weren’t coming up but if it’s down to the PPT then that’s fine.


#7

If somebody else has that issue here is more information:

You need to turn off “Searchable Add Reference Dialog” and restart Visual Studio if you have PPT installed.

Tools->Options->Productivity PowerTools