"NETMF and Gadgeteer Package 2014 R2 Beta-3" on Hydra and ENC28 - Ethernet is not working

Hi Gents,

I have tried the latest firmware (NETMF and Gadgeteer Package 2014 R2 Beta-3) on our Hydra board. But the Ethernet supported by the ENC28 module is not working (I can not ping the board)

FEZconfig reports version 4.3.2.0 now for both TinyBooter and TinyCLR.

Before testing the Ethernet I set (with FEZconfig) Hydra static IP (disable DHCP).
Ethernet was working fine (apart of some reliability issues) with the “NETMF and Gadgeteer Package 2014 R1” firmware on our board.

TinyCLR upgrade I have tried with MFDEPLOY tool as well, but still same result.

Is there someone getting the Ethernet working with latest firmware on Hydra+ENC28?

Thanks
Dimitar Penev

Can you set the network configuration through code and not FEZ Config and see if that helps? Can you also post a minimal program that reproduces the error?

Hi John,

I am actually new to NETmf and Hydra so let me explain what I do.
Probably I miss something simple.

  1. I don’t put any custom software on this board.
  2. I have updated the TinyLoader following https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra and “Method 2: Ground MISO and Power-cycle/Reset”
    And I have executed Update.bat from GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\FEZ Hydra\Loader. (This from latest firmware 2014R2Beta-3)
  3. I have confirmed with FEZconfig I have 4.3.2.0 TinyBooter
  4. I have updated the TinyCLR (hex files in GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\FEZ Hydra\ from the 2014R2Beta-3 ). Both FEZconfig and MFdeplow was tested.
    5.FEZconfig reporte now TinyCLR revision 4.3.2.0
    6.In FEZconfig Netowrk Configuration window I disable DHCP and set
    IP 192.168.1.201 and mask 255.255.255.0
  5. Should I be able to ping the board from external PC in the local network now without any additional custom software?
    This was working with 2014R1 (based on NETFM 4.2)

If above doesn’t clarify my issue I am willing to try to set the IP from the software. Can you please point me to an example or link I can start with?

Thank you once again.
Dimitar Penev

@ dpenev - you still have to initialize the Ethernet interface in software.

Hi Mike,

Thanks for the help!
I have managed to write simple application to set the Interface IP address
so I finally got my ping :slight_smile:

As per my very initial observations it seems the latest firmware has more stable Ethernet stack than the latest 4.2 one.

Best Regards
Dimitar Penev

@ dwc - double posting to a thread that is a year old is not going to get you an answer any quicker…