Main Site Documentation

NETMF 4.1 and Visual Studio 2010


#1

I have some very good news for you guys. The new SDK 4.1 is online and it includes 10000 features, all free to you :slight_smile:

First thanks to the beta testers. I will be adding 500 points to everyone who gave us feedback on the beta.

Now, while new SDK is online, the website needs some updates, like the warning about not supporting VS2010. We are out of time today, so we will wok on this tomorrow.

Thanks you very much and enjoy 4.1 :slight_smile:

The release notes http://www.tinyclr.com/release-notes/


#2

Cool will upgrade beta now.


#3

Awesome. Installing now!


#4

Here is a link to a great video for updating the firmware of the FEZ Cobra.

I followed that word for word without much issue… except that my first file transfer (upper case X) of TinyBooter hung at 3%. I clicked cancel and crossed my fingers that it wouldn’t “brick” my Cobra. Tera Term freaked out for a minute, but I was able to restart my transfer and everything went quickly and smoothly from there.

In Visual Studio, the FEZ project templates are a nice touch. I like the icon.

As mentioned in the release notes, I’m not able to deploy and run my old 4.0 projects (after upgrading to 4.1) and I can’t figure out why. There doesn’t seem to be much difference between the 4.0 and 4.1 project files. It was easy enough to just create a new 4.1 project and copy my code… but stuff like this really bugs me. Anyone know why the following error codes show up?

Resolving.
Link failure: some assembly references cannot be resolved!!
Assembly: SimpleTemperatureReporter (1.1.0.0) needs assembly 'GHIElectronics.NETMF.Hardware' (4.0.3.0)
Assembly: SimpleTemperatureReporter (1.1.0.0) needs assembly 'Microsoft.SPOT.Hardware' (4.0.1681.0)
Error: a3000000

Anyway, nicely done GHI! I bought 2 Arduinos years ago when it was just getting started, but I never managed to do much more than blink some LEDs in pretty colors with them (and I sunk [italic]dozens of hours[/italic] into getting various data logging/control projects going.

After a week or so with the Cobra, I’ve gotten Internet connected data loggers going with minimal fuss. If this is just the start, I’m really optimistic about finishing some projects that have been in my head for decades.


#5

See the error, your project still depends on 4.0 where it should be using 4.1 instead. You can solve this by removing the GHI assemblies from your project and then adding them back.

Since this is a major version upgrade, I highly suggest you make a new project.

Thanks for the lovely feedback and we are glad you love what offer.


#6

Hi,

I deinstalled all softwares used for FEZ Domino and installed VC#2010 and all the other associated softwares including NETMF 4.1.

Firmware upgraded correctly to FEZ Domino.

I attempted to try the USBclient Mass Storage example code in the latest beginners guide online. Everything compiles correctly but it throws the InvalidOperationException exception listed in the code.

I’ve tried closing out VC#2010 and pressing the reset button to see what happens.

What is this code supposed to do exactly? I was thinking it would allow me to see the installed SD card in the Domino as a new drive on my computer. Is this not the case?


#7

Yes that is what the example is supposed to do


#8

I attempted to try the USBclient Mass Storage example code in the latest beginners guide online. Everything compiles correctly but it throws the InvalidOperationException exception listed in the code.

Did you read the whole chapter? Did you see the important notes about debugging over serial? If you did then are you debugging using serial? :slight_smile:


#9

Wooooooooooooo :dance:


#10

I’m live on 4.1 and VS2010 so all sweet - even upgraded a project or two to check, and deploy and debug all works fine :slight_smile:

Only thing I found a little tricky first up was how to add the GHI references back in - had to navigate to the GHI directory and select the DLLS. Is that normal?


#11

DOH! No, I’m one of those guys that jumps to what I think I need in a manual. :slight_smile:

So, I need to set the Domino up to use the serial port as a debug port instead for the code to work? If I don’t, it’s like opening one port to do 2 things which the Domino is not programmed to do anymore because of the overwhelming tasking of this.

On my board, there is no jumper installed but the holes are there to put one. I assume this was done to protect the port from the warnings in the manual from happening.

To clarify, the jumper on the Domino needs to be in place at all times while using the USB client code, right?

Has anyone attempted using an XBEE module for the serial connection to debug? It would really be nice to do that but I understand timing may be an issue with this due to the latency involved with the modules.

Thanks!


#12

Hello guys ,

I got an exception when I try to start a new MF project

before I have installed the new GHI SDK , I have uninstalled VS2010 Express und Installed VS2010 Pro

After the installation was finished I have installed the new GHI 4.1 SDK.

I this a known problem?


#13

I had problems with the replacement Microsoft.SPOT.Debugger.CorDebug.dll but using the default dll and everything seems to work fine


#14

cypher, did you uninstall GHI SDK and NetMF SDK before reinstall of VS2010 Pro, and then reinstall them in the right order?

One more thing to try is all other project types to see if it’s just a problem with the Cobra windows app template.


#15

I found it :whistle:

Next time I have to read the notes until the end :wall:

From Readme.txt

So I have deinstalled the GHI SDK and MS SDK and after complete reinstallation of both SDK’s it works.

But anyway thank for the hints from Brett and Peter


#16

Brett, the GHI assemblies should appear in the .NET references with the Microsoft ones. Maybe you are using an older 4.0 project. You will not see them in that case.


#17

I just loaded the GHI 4.1 MF SDK and noticed that there are new project types for the different GHI platforms such as Cobra, Domino, EMX etc. These show up when you start a new project or add a project to an existing solution.

I was wondering what new functionality the GHI specific project provide?

My current project, which was using the GHI 4.1 Beta, loaded fine after installing the GHI 4.1 SDK and updating the references.

I am currently developing a project on two platforms, the Domino and the Cobra. The Domino gets it input from a serial port, and the Cobra gets input from a serial port and a TCP connections. My final target is a Rhino with the W5100 module unless I run out of memory.

I use a pre-compiler flag, with #if statements, to include the TCP specific code when compiling for the Cobra.

Can we still continue to use the MS MF generic project types for future projects?
Is it possible to change the target platforms on the GHI targets after a project has been created?

Might want to add something to the ebook on the new project types.


#18

The new ones you see are templates. There is nothing special about them, easier for beginners.


#19

Gus, you were right - the only time I saw that specific behavior was when i had opened an existing project. All other times I could add the references as expected, directly from the first tab in the dialog box.

I really like the fact that you can create a new project with the template and get some default references. Means as you say Gus that a newbie does not have to remember to add the base hardware refs to get past step 1.


#20

Yeah but only to blink an LED :slight_smile: We wants newbies to start learning about adding assemblies because this is very important :wink: