Main Site Documentation

.NET Microframework 4.3.1 (Porting Kit)


#1

Hi guys please i need help

.NET Microframework 4.3.1 (Porting Kit) where can i get this port

or did this port is same this source [here]
(https://github.com/ghi-electronics/NETMF-Open-Firmware) GHI NetFM Open-Firmware

i have version 4.4 i can compile but i want earlier version 4.3.1 of PK or is this one


#2

it would make sense if you rephrase your question because its not clear what you really want…

as of 4.4 the porting kit is no longer necessary and the last released porting kit is 4.3 RTM (QFE1)


#3

I have 4.4 sources and i created Nucleo Stm32f411ret6 firmware

Now I’ve got 4.3 qfe1 and stm32f4… from codeplex and tried to create firmware but it showed me an error not such file or directory ‘wininet.h’ and that error do not allow to finish compile firmware for discovery as default…

So procedures seems to be different

I have win10 pro,vs2015 ent.,keil 5.06 …

I can compile 4.4 but can not compile 4.3.x …

I’m trying to figure problem same problem i face when i tried to compile netduino 4.3.x

But somewhere i read
Need win 7 ,win 7 sdk , vs 2012… ,keil 4.56

So all what i need helps to compile version 4.3.x of .net micro framework for discovery on win10 ,vs2015 amd keil 5.06 (since 4.4 is compiled well with no problem) or i need to setup new system for 4.3.x


#4

You should be able to use the same setup…


#5

Bu it showed me an error with existing setup

Missing ‘wininet.h’ …

When i tried to compile for 4.3 but in 4.4 is compile well so that make me confused and after searches wininet is included in Microsoft SDK 7.1 which is used for vs2010 …


#6

What solution are you trying to compile?


#7

discovery stm32f407vgt6 and stm32f411ret6
Also same is when i tried to compile netduino 2


#8

call cd C:\xxx\NETMF4_3
call setenv_mdk 5.05
call cd C:\xxx\NETMF4_3\Solutions\BioSnapper
msbuild /t:build /p:flavor=release;memory=flash
call %SystemRoot%\explorer.exe “xxx\NETMF4_3\BuildOutput\THUMB2FP\MDK5.05\le\FLASH\release\BioSnapper\bin”


#9

call cd C:\netmf\netmf431
call setenv_mdk 5.06
call cd C:\netmf\netmf431\Solutions\Discovery4
msbuild /t:build /p:flavor=release;memory=flash
call %SystemRoot%\explorer.exe “C:\netmf\netmf431\BuildOutput\THUMB2FP\MDK5.06\le\FLASH\release\Discovery4\bin”

and i’ve got this kind of error

C:\netmf\netmf431\CLR\Tools\StubWinHal\stdafx.h(20): fatal error C1083: Cannot open include file: ‘wininet.h’: No such
file or directory [C:\netmf\netmf431\CLR\Tools\StubWinHal\dotnetmf.proj]
C:\netmf\netmf431\tools\targets\Microsoft.SPOT.System.x86.Targets(162,5): error : Build failed: StubWinHal.cpp [C:\netm
f\netmf431\CLR\Tools\StubWinHal\dotnetmf.proj]


#10

i think one of your targets files is wrong.

I can send you mine if you want.


#11

please sent it,maybe i did somewhere mistake


#12

In your email…