Main Site Documentation

.NET MF 4.3 installation does not recognize VS2012


#1

I have attempted to find an answer to this in the Microsoft forums with no luck so I thought I would see if anyone here has ran into this problem.

I am currently using Visual Studio 2012 Premium edition installed on a Windows 7 x64 machine. For some reason when I attempt to install the .NET MF 4.3 it reports that VS2012 is not installed. Now i have tried removing and reinstalling Visual Studio with no luck I have also attempted to install the Express edition with no luck either. Does anyone happen to know what registry key or file the installer is looking for to prove Visual Studio 2012 is in fact installed.

My concern is that I had previously had VS 2005 and VS 2008 installed (both were removed before installing 2012), and there is something left over that I have missed. I would really like to avoid doing a full format refresh of the computer.

Thanks in advance for your help.


#2

I didn’t have such issue. Have you rebooted the system after installing VS2012. Don’t really have a good answer for you. Also running W7 with VS2012, but no issues.


#3

Thanks for the reply, yeah I have rebooted, uninstalled, reinstalled, even searched the registry for left over keys from the previous installations with no luck.

I have a personal Win 8 machine with VS Ultimate 2012 and had no problems at all. But the project I am building is actually work related and I really wanted to avoid going to IT and asking for a new image as that is never pleasant and I will loose access to my PC for a few days. But this is starting to look like my only option.


#4

Looks like you had a lot going on with that system, considering 2005 and 2008. I think it is a good time to give that machine a full re-install as you are already thinking about .


#5

As it is an IT made image, can you check if any Security Policy is applied to the image, that would probably limit your rights in instaling the NETMF 4.3.

Another idea would be to install eveything using an Admin account, if it is not already the case…