.Net Gadgeteer And Visual Studio 2010 express & SP1/Windows 7 64bit, not GHI/Gadgeteer/NETMF modules showing in toolbox

OK, So I am a late bloomer to this stuff maybe, but,

I ordered the FEZ Spider board and was so excited.
I followed the instructions for downloading and install.
Went to the tutorials to start my first project,
And boom, first thing off the bat, the FEZ HYDRA shows up in the no modules in the toolbox.
So I cant change the motherboard…

Then I select Show All in the toolbox, and there are most of the modules, along with 5000 other items.

In C# Express they dont even show up.

I fiddled around and got some things to work that way, but the software side of the product is still not as advertised.

I have uninstalled rebooted, reinstalled twice now with no help.

I still cant get VS to create a project.

Can anyone help me with this.


Can you provide more info about what exactly have you doenloaded and installed?

SO from the support page I followed these instructions to the letter.
My firmware did update to 4.2…

Still no visula studio 2010 support for projects.

There are no GHI, Gadageteer, or MS NEFMF items in the toolbox.

And no Gadgeteer application project type to select for New Project.


Here is a screen shot of my VS C# Express with Select All turned on.

And one with the New Project open

So on your second image, the new project, it seems you have the Gadgeteer and Netmf project types. But the list of templates under the Gadgeteer folder looks completely wrong.

So I suggest you uninstall the GHI SDK, then uninstall the netmf SDK, and then try loading that all again. But as Architect asked, can you please confirm the filename of the two SDKs you installed?

Can you tell us if you ever had VC# installed before, or did you install that fresh too?

1 Like

Thanks. I did remove and reinstall in the order on the install page for 4.2.

Rebooted, and that worked.

My version of VS Ultimate has been on for a few years now. However VC Express is new with SP1.
I removed everything rebotted, andnow it is working fine.

Thank you very much.

Great! Why did you installe Express when you already have Ultimate ?

I try to keep my personal projects very small.

From the ultimate side I am loaded with stuff, yes I know the toolbox will load all the items anyway.

But SSIS and Biztalk functoids take a lot of space.

Loading my ultimate take a long time and even more memory.

express, is a smaller footprint.