Main Site Documentation

Need some help with USB->Serial cable connected to COM1 on Domino


#1

Hi,

I think I need some education on Serial ports.

I purchased a USB to Serial cable. I installed the driver for it. It now comes up as COM3 on my PC.
If I connect the Tx and Rx to the Domino’s COM1 in and out pins, will communication work? I believe my cable outputs RS232, is that right? But the COM1 on the Domino is TTL UART?

Do I need to buy a “TTL-232R-3V3” as stated on page 76 of the “beginner’s guide to NETMF”, or can I still use the cable I bought with some minor mods?

When I tried the example on Page 76, which sends text, I received heaps of weird ASCII on my Term program.

I also tried the loop-back example on page 78, with a wire connected from COM1 in to out on the Domino. The code just sits to the “UART.Read” line. Why does this occur?

Thanks,
RJ


#2

Sounds like you need TTL rather than RS-232.

Email me your address and i’ll send you one: markh@ rris.com.au

You can use a MAX232 chip to convert your TTL to RS232 and back.


#3

Watch out that RS232 levels could be up to ±12V so you might damage the UART pins on the Domino which are 0-5 volt no more. You need TTL to RS232 converter like MAX232.


#4

Note that you have damaged your FEZ completely or the pins related to serial.

Always search teh web or come here for answers on connecting things before you connect them. If you are very new to hardware then just use the components we provide here to make starting up easier for you. For example, we already have RS232 shield that you could have used.


#5

Oh no, I’ve made half a brick out of my Fez!!! A trick for young players. ::slight_smile:
Looks like I now have a hack Fez domino. I’ll be doing all my testing on this one from now on. Looks like I really need a Panda now.

@ MarkH: You are too kind, I’ll definitely take you up on your offer.

Why Fez? Not only are the boards fun and easy to work with, but the help and support provided by the Fez community is unprecedented.


#6

Crap, that sucks dude. It looks like it shudda worked right :wink:


#7

Also RJ, if you really have fried part of your FEZ i can switch the processor out for you if you want (since your in Aus). I’d just need a new USBizi to stick on there.


#8

Since you used USB to Serial cable. so there is a chance that the levels are ±5volts. Maybe the IOs are still safe. I am not sure.


#9

Do you have an Arduino or something to confirm that the IO really is hosed?


#10

Correct me if I’m wrong but wouldn’t a simple Blink LED work to verify if he has fried those pins?


#11

I did a pin test, and it seems only pin 0 is not working. Pin 1 still works.
One COM port down, two to go. ::slight_smile:

@ Mark : Thanks for the offer, but losing one pin isn’t so bad. Had I fried the USBizi chip I would have taken you up on your offer. I’m guessing you are advanced at soldering components, I wouldn’t even dream of de-soldering, let alone soldering SMB components.

Thanks for everyone’s comments.


#12

I’ve soldered far harder stuff than the USBizi. USBizi should only take a minute to desolder/replace then another minute to check for bridges.

Let me know once you’ve fried the other uarts :stuck_out_tongue:


#13

Mark can you and I be friends? :wink:

(you’ll see I have some USBizi chips and no chance of soldering the suckers!)


#14

@ Brett, both you and Mark are both in Australia too, so that’s even better.


#15

oh yeah, I knew that - no point getting someone lined up for a solder job only to ship stuff around the world (even though Perth is, well, “distant” :slight_smile: )

:wink:

PS: I too have a MAX chip you can have once we get the AU order sorted!


#16

Thanks Brett I appreciate the offer, but Mark has already sorted me out with the MAX chip.

I am looking forward to the AU order too.


#17

Brett, if you want stuff soldered i can help you out. If you have more than 2 or 3 though, a cheap mylar stencil would be appreciated though so i can do them fast (smtstencil.com)