Main Site Documentation

Need some help with my g80 design


#1

For my project I designed a little board for the g80. I tried to consider your suggestions from https://www.ghielectronics.com/community/forum/topic?id=24160, thus placing crystal and caps as near to the ic as possible, not using autorouter, etc. Nevertheless, when I plug in the board, it does not get recognized by windows. I checked for shortcuts or wrong connections, but everythong seems to be ok. My question: could you please just make a quick check on my desing to lead me into the right direction?

My eagle files can be found here:
https://owncloud.cssteam.at/owncloud/index.php/s/rb5KSWjxTxdfSt8

Thanks, and best regards,
Florian


#2

The only error I can spot is that the ground plane around the crystal is not showing as connected to the rest of the ground plane. There is a RATSNEST line showing indicating that there is a missing connection. See attached.

My only other comment would be that next time you do a design, beef up the power tracks to at least 1mm (40mils). Your circuit is likely to be low power so probably won’t be an issue but be aware of this anyway.


#3

Thanks for your reply! I have already fixed that by soldering a little wire. Still no luck. Strangly when I check for shortcuts, it seems that GND and VCC are connected as long as the board has no supply. When I connect it to power, the shortcut seems to be gone. Is this a feature of the chip? Took the chip may damage already?
Second strange thing I noticed: When I measure voltage of LDR0 during power up, it only reaches ~1V and then slowly drops to 0V. Shouldn’t it at least get >= 2V (=TTL High)?
Best regards.


#4

by “shortcut” I assume you mean short circuit? If so how are you measuring it? It’s possible that is just a diode leakage, and if you’re using a multimeter to check for it you can reverse the red/black connections and it’ll disappear (its related to the power that the continuity test provides, energising the circuit)


#5

You are right, I am using a multimeter, I guess this could destroy the g80 as well?
While playing around and reinstalling drivers I managed to get some “reaction” from my board. It seems that the g80 is constantly rebooting. My first thought was a mis-calculated capacitance for the external crystal caps. Application note https://goo.gl/C70t99 provides details about how to calculate those values. My crystal http://www.mouser.at/search/ProductDetail.aspx?r=815-ABLS-12-B2 has a load capacitance of 18pf. With a stray capacitance of 2pF-5pF it should be 26pF-32pF for the external caps. I don’t know why but somehow I used 15pF for my board :open_mouth: I will change those caps and see if it helps.


#6

the voltage and current on a multimeter continuity test will not usually harm electronics so I don’t think that’s a problem - but it does mean your suspicion about a short circuit is not necessarily correct.

caps are an important thing to calculate, for sure. If you have access (or can find a way to get access) to an oscilloscope you’ll get much better information about whether that is or is not your issue.

Another thing you can test is making sure your PC has sound turned on, and seeing if you get device connected/disconnected sounds as the board resets (it should if it’s coming up and starting the USB lines appropriately)


#7

Again you were right! As the image shows, the oscilloscope measures 12MHz. When I connect the board to my pc, I can hear the connected/disconnected sounds constantly going and device manager shows an unrecognized device, the detailed error says “Device Descriptor Request Failed”. I re-checked vcc and ground pins but they all have the right voltage. The lm1117 connected to 5v usb for power supply is generating 3.28 instead of 3.3V, but I guess this is within acceptable range. Any suggestions?


#8

Check for a short on the D+ and D- as I’ve seen failures to detect the device because of this.

Have you checked that there are no shorts on the processor pins?


#9

If you have a short circuit, you’re usually not going to get to the point that Windows can see a device at all - you usually have the USB port hardware that invokes it’s protection and just shuts the port down before any enumeration happens and it certainly won’t stay visible for long if the current protection is occurring. Like @ Dave I’d doubly make sure there’s no obvious solder problems around USB and CPU pins


#10

I’ve seen it fail to enumerate the device if one of the lines are shorted to ground but you still get the beeps and then a window pops up saying that the USB device was not recognised. Worth checking the CPU Pins for shorts anyway.


#11

Sadly I didn’t managed to get it running. I alread received a G80 THP module and will redesign my board to work with that. Thanks for your support!