Main Site Documentation

Mysterious microSD Card


#1

We had a problem with microSD Cards, first out application worked - then it did not. And so on…
After reading posts in this forum Kingston was blamed… we went to Sandisk… it worked for a while.

By chance I placed on of a 2 GB FAT Sandisk microSD cards in my PC (Win 7 Ent 64-bit)… now it became a 8 GB FAT32… :o

Then it was place in a Win 7 Pro 32-bit - then it was 2 GB FAT again… then back to the Win 7 Ent 64-bit… now it was 2 GB FAT :o

After a while it became 8 GB FAT32 on Win 7 Ent 64-bit ::slight_smile:

I do not understand this… somewhere there must be a BUG.

On FEZ Mini the problem is seen like this: PS OK, FileSystem OK, Format shows OK - but exception on create file. Other times the code works fine.

Has some one else seen something like this ???
Is it Windows, NETMF, FEZ Mini or what ???


#2

Have you tried formatting the card?


#3

Or a doggy card? There are a few fake cards on the market. Take care with where you buy SD cards… :slight_smile:


#4

Just out of curiosity… :think: …when Win7 64bit, reads it as 8GB - have you tried installing some thing near 6 to 8GB.
Maybe it just a Display error; like the “Font”- “8”… i dont think it actually gives you 6GB more… if it does; then it a neat Bug… :slight_smile: … from my point of view… buy 2GB… get 8GB.