Main Site Documentation

My laptop won't cannot connect to Cerberus main board


#1

My gadgets arrived today (much quicker than I ever expected)… thanks! :slight_smile:

However I’m having problems trying to deploy my first app to the device.

For some or other reason my Windows 8 laptop is refusing to connect to the board. It detects the USB-Serial SP Module as COM6, but not the Cerberus board itself.

I tried all the following already:

  1. Reinstalled everything
  2. Tried to ping with MF deploy… no response (in USB and serial mode)
  3. Tried the new GHI Configuration Tool.
  4. Replaced the USB cable and the ribbon cables
  5. Tried a different Cerberus board (I have two)

At this stage I suspect the culprit is the USB-Serial SP Module and not the Cerberus boards that is causing the problem. Unfortunately I only have one of those. The reason why I think its the culprit is because there are no LED’s lit (Tx or Rx) on the USB-Serial SP Module at any stage. I would expect they should at least flash when I try to ping, right? On the Cerberus board itself, the red LED is on.

My questions are:

  1. Should any of the LED’s on the USB-Serial SP Module when I do a ping?
  2. Should I be using USB or Serial device mode when trying to program? I tried both and none worked. But I would like to know just for the record anyway.

It is getting a bit late now… but tomorrow I will try to make up my own USB_Serial SP module using a different USB to serial module I happen to have here. I will also try on a different computer just to see if that makes a difference.


#2

I am not sure if this is still an issue, but there were problems with USB 3 ports.

Maybe you could try using a USB 2 port, if you don’t have maybe a USB 2 hub will do the trick.


#3

Do you have a USB SP or DP module? The USB Serial SP you have requires the mainboard to be set up in serial debug mode, so the standard SP or DP are easier for first time use.


#4

@ taylorza - Thanks for your reply. My laptop has three USB ports, only one of them is USB3. I tried on all three without any luck. I should also mentions that I often use this same laptop to talk to other gadgets via USB to serial converters. Anyway I will persist until I get this to work and will update this thread to say when I found a solution.


#5

@ Brett - Ahh… its the USB SP module (http://www.ghielectronics.com/catalog/product/437). Will I now need to buy USB Client DP Module instead? I hope not… postage to NZ is small fortune.

Is there any way to set the board into serial mode without a DP module?


#6

Is it a “usb serial sp” or a “usb client sp”? You point to the ‘serial’ one. You need the “non serial” one unless you get into serial debug mode… I’ve been trying to find a reference that talks about Cerberus being capable of this but can’t seem to find one…


#7

The ‘client’ modules connect to D socket, the one you have is a U socket, so they’re not compatible.

Ps, welcome, I’m just across the ditch in Sydney. I probably have a SP client module I can loan you to get working, in a pinch?


#8

As of right now, the Cerb-Family of Boards do not have Serial Debugging capabilities. A custom firmware would need to be compiled to allow for dynamic serial debugging or to force it into serial-only debugging.


#9

Keep in mind the USB Client DP Module can only really deliver current allowable from your USB hub. If you are needing a lot of current, go with the USB Client SP Module and tap in your more capable power supply as needed. Make sure you disconnect the power line(s) going back to the SP Module though! I had to do this for using the cellular board which can draw up to about 2A.


#10

@ logictechs - There is a new module for higher power requirements:

https://www.ghielectronics.com/catalog/product/441


#11

so for @ Werner, you’ll need a “client” SP or DP module to be able to deploy apps. Sorry, no way around it :frowning:


#12

@ Brett - Thanks Brett. I think you answered my question. And thanks for the offer of loaning me a unit. But maybe its possible for me to make my client module. I’ll spend a bit of time researching that possibility tonight to see if that could work for me.


#13

You are right… That does like like a very nice module. I think if I have to buy a replacement that is the one I’ll get.


#14

No please don’t. Probably not what you want. Does not give you usb client capabilities ie you still can’t deploy code to the device.

As for diy, check out the Gadgeteer source on codeplex and see if GHI have the full eagle files for the D socket client modules.


#15

@ Brett - Thanks for the warning. I had a quick look tonight at http://www.ghielectronics.com/downloads/schematic/USB_Client_SP_Module_SCH.pdf
and think it will be quite easy for to make some kind of makeshift adapter for now. We are gadgeteers after all!


#16

It worked! My own USB Serial D client contraption allowed me to connect, upgrade the firmware and run code in debug mode on the device. Thanks to all for the advise. :slight_smile:


#17

Bonus cred points for that DIY effort so early in your forum “life” :slight_smile: !!


#18

@ wernert - Hats off to you sir… well done!


#19

@ wernert - what does it look like? :slight_smile:


#20

Would love to see a picture of your DIY solution!!