Main Site Documentation

My FEZ Cobra is not talking!


#1

:frowning: Help! I cannot communicate with my new FEZ Cobra. I have all the USB drivers installed, and am able to communicate with my Panda II, but when I plug the Cobra into the USB port on my computer nothing happens. MFDeploy cannot find it. I also tried the four-finger reboot, and that didn’t help.

More Info:

  • The red LED is on.
  • The network LED is blinking.
  • I have a 7 inch display plugged in.

#2

Do you see anything in the Device Manager?


#3

With the 7" display you might need to use a powered USB hub or an external power supply for the Cobra.


#4

Yes and stick to 7.5", 6V may work too


#5

Thanks for the quick replies.

I dont’ see anything in the Device Manager, and there is no “beep” sound when I plug in the device.

I do have a 9V supply plugged in… I’m waiting on a 6V supply from RobotShop.


#6

Did it work before having the display plugged in? Sounds like the screen is drawing too much current with the power supply you have attached.


#7

Thank you for your reply.

I bought the board and display at the same time, and connected them together before powering them up.

I’m at work now, so I can’t try anything, but tonight I’ll try disconnecting the display.


#8

What if you connected the display wrong? Try it without display please


#9

Thank you Gus. I’ll try that when I get home from work later today.


#10

Gus, I disconnected the display and the card worked. I will get a better power supply and will make sure I reconnect the display properly. Thanks.