Moutaineer Eth can see but NOT PING in MFDEPLOY?

Hello guys,
i just got my mountaineer Eth and updated the firmware and have the latest beta GHI SDK with netMF 4.2 QEF2, so after the firmware was updated using the 4.2 version…and installing the winDriver… i opened MFDeploy, i can see the Mountaineer but when i click ping i get an error and tried to deploy using VS2010 and i get device not found …did i miss a step or something?


Does it work with official SDK and firmware from mountaineer?

do you mean i should uninstall GHI SDKs? and only install Mountaineer SDK…?

Note i have both SDK’s installed right now…

I never said uninstall :slight_smile: They should play fine together, just use the mountaineer firmware with mountaineer update instructions before you try GHI’s.

Thanks Gus,
but that’s exactly what i did i followed their instructions to flash the firmware and installed their SDK.
the firmware flash finished with a successful message i have the winUSB driver isntalled… after the firmware flash i removed the jumper wires and reset the board, i even unplugged and replugged the board and i always gives the same thing, MFdeploy fails to ping… also is the device name shown in MFDeploy correct? i wonder why it has all those extra number and letter at the end see the picture above…

I hope the mountaineer is not contemplated with the Spider against me ;), maybe they are going on a strike against me.
PS: i never used GHI instruction,didn’t know you guys have some for the Mountaineer, and if you do please point me to them and i’ll try them…


here is what studio has to say when i try to deploy a plan vanilla project… look how the name under Device= Mountaineer Eth_a7e70ea2 doesn’t match the name on the error below… see attached image…


and one more thing, how do i roll back the firmware because i can’t find it anywhere here:

no sign of the older firmware… can you please help me find the NON 4.2QEF2 firmware…


btw I’m using WindowsXP 64bit just in case no testing was done in that system, which i assume is the case since the INSTALLER for STDFU posted on Mountaineer site includes an Older version (3.0.1) for 64bit while the docs mentioned 3.0.2 which is the 32 bit version)… I’ve tried flashing with both and no change… i hope you can tell how impatiently i am trying to get this board to talk to me, so please if you know the answer don’t hold out on me…


@ Jay Jay - Having had a few issues with updates and i know you have been tearing your hair out with your spider and now your pointy hill has got me wondering…
Did you uninstall VS etc on your machine rebuild or was it a fresh XP and VS and SDK install?
Nothing seemed to work for me until i tried it on a virgin Win 8 box and all good straight away…

mine was not a fresh windowsXp it was a VM with VS2010 but never installed any netmf stuff on that machine… so it was fresh NETMF GHI and all…


anything anyone…

more info when i try to uninstall the Mountaineer USB Driver located under Universal Serial Bus Controllers… it just hangs and never finishes uninstalling… so i guess something is definitely wrong with the driver… did you guys test this driver on a WINDOWS XP 64bit ?

Please talk to me, and don’t let me talk to myself, I’m about to go nuts between my two boards not working…just say anything please at this point I’m open to any suggestions…

thank you for echoing back…

How about trying win 7 or 8 image?

I think we have only tested with Windows 7 so far, but I’ll have to check in the office.

The “Mountaineer Eth_a7e70ea2” display that you see is correct.

On see the section “SDK and drivers”, the original QFE1 firmware is still there, and at the moment I’d recommend to stay with it until we have done some more tests:

Mountaineer USB Driver download:

Mountaineer Gadgeteer 4.2 SDK download:

Does everything work with the original SDK and USB driver (you’ll probably have to go through the steps of chapter 6 of the QFE2 Update guide, with the “Have Disk” step, to properly install the old USB driver:

I hope that this helps at least in going back to the QFE1 firmware.

Hello Cuno,
thanks for getting back to me, i still can’t see the firmware on that page, either I’m blind or it is not easy to find… all i see in that section is three links:

Edit: and the reason why i upgraded in the first place is because when i installed everything and plugged in the Board i tried to ping it with MFDeploy and it didn’t work so i thought maybe it needed the latest firmware so I’m 100% certain that even with the previous firmware it will exhibit the same behavior… it could be related to WindowsXP 64 bit… please test both firmwares on WindowsXP 64 bit and let us know…

i don’t have those images ready, and it would require time and the right mood to install them… which i do not have at the moment… LOL

@ Jay Jay - I can get you one tomorrow if it would help.

Thank you Justin that’s nice of you, i’ll try to flash the OLD firmware first and see what happens if that doesn’t help.
then i’ll try to find my HP Laptop Power Adapter charge it and test with since that one has windows 7 installed or was it Vista…??? yes it has been that long since i turned it on… today’s tablets tend to make you forget you have a laptop LOL

Ooops, you are right… As a quick fix, I have put together a Web page with the old firmware. At the moment I cannot check whether this is indeed exactly the release version. I will do that tomorrow when I’m back in the office.