Main Site Documentation

Mountaineer USB deployment issue & impossible to erease with MF Deploy exe


#1

Hi guys,

i’ve aMountaineeer usb and i’ve updated to the latest firmwmare. 4.3.1 9 april 2014.

From Visual Studio 2012 i cannot deploy assemblies & from MF Deploy i can see the board and i can ping the Tiny CLR but i cannot erease the memory.

Here is the device capabilities… anything wrong???

HalSystemInfo.halVersion: 4.3.1.0
HalSystemInfo.halVendorInfo: Copyright Oberon microsystems, Inc.
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
HalSystemInfo.moduleSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
HalSystemInfo.systemSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
ClrInfo.clrVersion: 4.3.1.0
ClrInfo.clrVendorInfo: Copyright Oberon microsystems, Inc.
ClrInfo.targetFrameworkVersion: 4.3.1.0
SolutionReleaseInfo.solutionVersion: 4.3.1.0
SolutionReleaseInfo.solutionVendorInfo: Mountaineer Group
SoftwareVersion.BuildDate: Apr 9 2014
SoftwareVersion.CompilerVersion: 5030076
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 0
LCD.Height: 0
LCD.BitsPerPixel: 0
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

p.s. i’ve even an Ethernet one and that one works perfectly!


#2

I tried to downgrade to 4.2 QFE1 with Dfuse then back again to 4.3.1 the wole procedure seems working… i can ping the Tyni CLR but then no possibility of ereasing nor deploying assemblies…

can be a power issue? i mean i’m using a powered usb from my dell laptop… with the mountaineeer ethernet works… why with the usb version didn’t?