MFdeploy hanging on checking signature on Cerbuino Bee (not using USB 3.0 from solution on other post)


I have exactly the same problem as KevinJett when running on VMWare Fusion in 64-Bit Windows 7, using the latest SDK. Reading this thread, I went through the (immense pain) of installing the full environment on a native Windows 7 (64-Bit) Machine.

This allowed me to update the firmware, and deploy and debug my application.

Switching back to the VMWare version (my primary machine) I could no longer deploy the (exact same version) of the application. I get the same output errors as KevinJett.

Willing to experiment with any suggestions you might have :slight_smile:


We never officially supported any VM but it looks like more users are needing this so probably GHI will do some testing to support VM in near future. Unfortunately, GHI is limited with what it can do since this is also tied to Microsoft’s tools. Not sure if Microsoft would get a Mac and test NETMF tools.


Fully understood, and apart from the fact that VMWare is a very widely deployed solution, supported certification programs between the companies, there is the fact that until I upgraded to your latest SDK and Firmware, my solution worked just fine.

Hope somebody on this forum can find a way around this issue :slight_smile:


Then this is something we can fix on our end.

Thanks. Let me know if there is anything you need from my side …


Another update, not sure how useful it is to you, but it sure helped me. I installed a Bootcamp partition on my MacBook, with Windows 7(64) and the solution works perfectly. So, in summary … with the latest SDK and Cerbuino 1.2 board, I have the following situation

  1. Running under VMWare Fusion - Fails
  2. Running under Bootcamp on same machine - Works

Helpful notes. Will pass them to the team.

Yup I get the same, unable to deploy from VMWare Fusion 5. It’s definitely the USB drivers not working in VMWare.
I installed a development environment in bootcamp and everything worked fine on a 13" late 2011 Mac Book Pro.

I have exactly the same problem when running on VMWare Fusion, using the latest SDK, on my MAC Mini 2012.

Sorry, but I can’t use Bootcamp.

Can i use the old Firmware instead ?
But I don’t find it in the download area.

My Board is a FEZ Cerberus from the Kit.

Tx, Roland

old firmware packages can be found at

VMWare Fusion, has known issues with some USB drivers, I have no idea whether any of the suggestions found in the following links work, but you might want to try them before using an older firmware package that will lack any fixed bugs and new features offered by the current SDK.

Thank you very much Jeff!

first i will try to fix the problem with the given vmware links, before i test an older firmware.
I will report here my results.