Main Site Documentation

MFdeploy hanging on checking signature on Cerbuino Bee (not using USB 3.0 from solution on other post)


#1

I am trying to update my Cerbuino Bee and am having the hardest time. I think I have tried everything. I have made sure to go through any articles to make sure I’m not missing something.

**I looked at this post, http://www.tinyclr.com/forum/topic?id=8533, and the solution they came up with was to switch from usb 3.0 to usb 2.0. I am already running in USB 2.0. So that didn’t work for me.

Here is what I’ve followed:
-Used this article to get the correct versions installed, http://www.tinyclr.com/forum/topic?id=8498
-*Note: The new USB driver in the latest GHI package would not work for me. When I got to the MFDeploy.exe, it would not see the device when it was plugged in. I had to uninstall it and install the legacy USB driver (64 bit).
-Used this article for upgrading the firmware for the cerbuino bee, http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Cerberus

When I get to the last step of updating, it freezes on “Checking Signatures…”. After about 10 mins, it tells me, “Signature check failed for file Firmware.sig”.

FYI, Im using a VMWare VM for Windows 7 64 bit on a mac. I have never had any problems before connecting the device.

Any help?


#2

Then the SDK you are using will not work. There is one coming out tomorrow that should work fine. We are doing final tests.

Welcome to the community.


#3

Welcome to the community! Is this KevinJett in Nashville?


#4

Yes looks like it. Did you get him hooked on the fez drug? :wink:


#5

I’m afraid I may be guilty of that :wink:

Kevin’s a great guy that I met at DevLink. A very welcome addition to this community. Hopefully, I’ll see him again soon at a NashMicro meeting (on Dec 10th) :wink:


#6

Yep, this is Kevin in Nashville. I’ll have to admit, the drug is very addictive and my wife would probably be really mad at Ian if she knew he was the cause of it. :slight_smile:

Gus, thanks for the quick help. I have been stressing over this thing for a week now. I accidentally upgraded my version on my machine so the fez wouldn’t connect to it anymore til I upgraded the firmware. It’s been a nightmare. But glad to hear my problems might be solved today!

I’m planning on being a the meeting on the 10th. I need to show you what i’ve been working on. You’ll probably laugh at how I did some things. I been reading more blogs and tutorials than ever before. ha.


#7

The way to cure that problem is to build something awesome for your wife! I’ve discovered this past week that my wife is a huge fan of Pacman :smiley:
http://www.tinyclr.com/forum/topic?id=9807

Excellent! I promise no laughing (unless that’s your goal!) I can’t wait! BTW, I’m still looking for a food sponsor if you know someone interested :wink:


#8

Gus, I hate to say it but it didn’t work for me. I attached a screenshot of the files and “Checking signature” hang. I uninstalled all GHI and Gadgeteer Core and installed from the latest download from today. I installed the DfuSe software and erased and downloaded the new DFU file then went to MFDeploy and it did this again.

Any new suggestions?


#9

I see you ate using mfdeploy to update, which is fine if you have latest tinybooter loaded.

Make sure you have latest tinybooter. Look at display to see version if you have display.


#10

This is the file I used from the latest download from today. TinyBooter_4_2_3_3.dfu

Is there another way to update the firmware?


#11

I forgot you are using cerbuino sorry. The only thing left is power.

Checking signature take few seconds but not minutes.


#12

Well it will eventually fail with error checking signature for firmware.hex. Any other suggestions?


#13

Can you try on a non-VM machine to help narrow down if the VM is the problem or maybe something else. Be sure you’re powering from a powered USB hub and also try a different USB cable.


#14

I do not not know about the cerbino, but I do know that there are known USB issues with the Hydra and a Fusion virtual machine.

Another MF board manufacturer’s technical specs show limited or no support for USB deployment.

Bootcamp may be the way to go with Apple.


#15

ok, so switching to a non-vm machine got the firmware upgrade to work. Yay! That’s been a pain. But now I have a new pain. VS will not deploy my app anymore. It worked before. I’m guessing it has something to do with the new USB drivers and VMware Fusion. When I plug it in, I get power on the board but when I try to deploy it I get this error.

An error has occurred: please check your hardware.
Request failed
Source: Microsoft.SPOT.Debugger
Stack :
at Microsoft.SPOT.Debugger.Engine.Request.Wait() in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 761
at Microsoft.SPOT.Debugger.Engine.SyncRequest(OutgoingMessage msg, Int32 retries, Int32 timeout) in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 1963
at Microsoft.SPOT.Debugger.Engine.ResolveAllAssemblies() in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 2941
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 869
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

Do you think it will work again for me on VM? It’s my main machine. I’m going to try it on my other machine later and send an update.


#16

Was it a new project or old one. You need a new project since you have updated the SDK.


#17

I tried a new and old. Both failed with same message. I tried it on my non-vm computer and it worked fine. But that’s my wife’s computer so I really need to use the vm computer if possible. So it’s definitely a problem when using VMware. What confuses me is that it has always worked fine on my VM.


#18

The same board worked before? What changed!?


#19

Yep, same board. I bought the FEZ at the beginning of september 2012 and it had the same firmware that it came with until i upgraded it yesterday. I had the GHI release from august installed and had 4.2 QFE2. With those versions, I never had a problem before. Now, im using new firmware from yesterday and new GHI package from yesterday with QFE2.


#20

We didn’t change anything in the “USB area”! Maybe try using the WinUSB drivers? http://wiki.tinyclr.com/index.php?title=WinUSB_vs_NETMF-USB

Do you have the old SDK still? I am curious if you put it back it it will work again.