MFDeploy doesn't see FEZ Spider

Hello … I just received my FEZ Spider starter kit this week.

I have downloaded and installed the .NET Micro Framework, v4.2, and the latest GHI drivers, etc. I am running 32-bit Windows 7 Pro (all latest patches, etc applied) and VS 2010 Pro.

After the GHI drivers were installed, I updated the firmware on the Spider. At first it didn’t work but after some research on this site, I learned to manually update the device driver. Everything looked great. It is now booting up with Version showing on the attached display.

I set the dip switches back to default and reset the board. I hear the usual tones and see “GHI NETMF Debug Interface” under the USB controllers in the device manager.

However, when I go to deploy anything to the device, VS gives me a “device not found or cannot be opened - USB:Gadgeteer” error. So, I tried to see if MFDeploy can see the device. I set MFDeploy to USB (from serial) and nothing …

After more research on this site, I back out all software expect VS 2010 and reloaded (twice!!). Micro Framework installed first followed by GHI drivers, etc. I updated the firmware on the spider again … no problems. I still see nothing on MFDeploy.

I tried the same process on my MAC, booted to windows 7 pro 64 bit, but I had the same problems.

I really don’t want to send this board back … it looks like it is working but there is something I’m missing in windows or a driver or something.

Any other ideas?

Did you try to erase all the memory map on the FEZ before installinge the NETMF 4.2 hex files ?

hey dgies68, welcome to the forum !
sounds to me like the drivers didn’t load - the fact that the firmware shows is a GREAT sign. So show us the device manager screenshot to see the driver - and follow the manual install of the driver, in bold, at

Here is the screen capture from the device manager and from the MFDeploy. Still no joy after following the process from

How do I erase memory map on the FEZ if I can’t get MFDeploy to work? I know I’m missing something. Do you have a procedure?

You have 4.2 but not 4.2 QFE2. Please use the exact downloads listed on the support page.

And welcome to the community :slight_smile:

Hi Gents,

Thnx Mr. Gus for your quick responses :slight_smile:

and I think I’ve reached now exactly the same issue of Mr. dgies68 at the same step, but with FEZ Cerbuino Bee …

So … should I try the same thing? I mean to (use the exact downloads listed on the support page.) !!

Although I was following the steps of (Firmware Update FEZ Cerberus)
@ GHI Electronics – Where Hardware Meets Software

Thnx in advance :slight_smile:

@ Petabyte, if you downloaded the 4.2 RTM not 4.2 QFE2 update, then you need to at least uninstall the GHI SDKs and then netmf sdk, then reinstall as per and then make sure you apply the firmware again

@ Brett Thnx for the reply :slight_smile:

Dear Brett, I was following the exact page that you provided (.NET Micro Framework)

Sorry, but I got confused now, the link in that page, which is for (Microsoft .NET Micro Framework 4.2 QFE2 SDK) is directing me to this page:

Then I found and downloaded the RECOMMENDED DOWNLOAD, which was “SDK 4.2 (RTM QFE2)”

So it seems that RTM & QEF2 is the same thing in one file, isn’t it?

and do you think this framework has anything to do for pinging the board??
because I think it is needed only for VS 2010 …

Thnx for you all :slight_smile:

Yea, I’ve just checked that, the .NETMF that I am using is already SDK 4.1 (QFE1) !!!


You need QFE2

Woohoo! It is working! The key was QFE2. My apologies, I don’t know how I missed that. Thanks for all your help.

It works :))

Thnx a lot guys :))

I have a problem with my new FezSpider, when I plug it on my Win XP PC recognize “GHI BootLoader Interface(COM10)” without error, but when i try update firmware with “FEZSPider Firmware Updater” return “No Responce from device”; so i tried connect with Hyperterm and download TinyBooter File, but when i try to RUN Firmware return “Bad Firmware”. I tried all way… reinstal usb driver, use a Win/7 Pc… nothing… dont work! can someone help me? Thank you.

Sorry for my bad english.