Main Site Documentation

mBuino not recognized on mac


#1

10.9.4 Mavericks
Power from usb is delivered. LEDs flashing. Awesome.
Can’t see the device at all from the mac
not showung up as usb device
ls /dev/* does not show it
ls /Volumes/ does not show it up as well

Suggestions? I’m a all mac person. Don’t have easy access to PC / Windows.

:wall:


#2

Welcome!

Have you tried to hold the reset button down for a few seconds while it’s connected?

I had to do that on my PC to get it show up as a device.


#3

Did you hold the reset button for few seconds?


#4

Thanks that works

Shows up as “CRP DISABLD” is that right? I can see the firmware.bin file. Tonight I will write something new. thanks


#5

Exactly right!


#6

@ DaddyOh - You wild probably run into problems. Please see this thread https://www.ghielectronics.com/community/forum/topic?id=16612

I hope between you and other community members we can document how Mac can be used with these NXP chips.

Welcome to the community.


#7

:smiley:

Okay got this working on my daughter’s ThinkPad laptop. I can compile and load a program easily. Thanks for the help.


#8

I got it working on my Macbook Pro / OSX.

Make sure you are running things in the terminal! Copying from the finder doesn’t work!

 ~  cd /Volumes
~  rm CRP\ DISABLD/firmware.bin
~  cp ~/Downloads/usbprank_10.bin CRP\ DISABLD
~ 

Also, you can use df to find your device


~  df
Filesystem    512-blocks      Used Available Capacity  iused   ifree %iused  Mounted on
...
...
/dev/disk2            64        64         0   100%       16       0  100%   /Volumes/CRP DISABLD

#9

iwritecode

Thanks, I will have to try that when I get some free time. I would love to be able to manage my mBuino(s) from my mac.

Eric


#10

@ DaddyOh - I played a bit on my Linux box, and didn’t have many problems. I used https://developer.mbed.org/questions/3512/Can-the-11U35-actually-be-programmed-usi/
as a guide. Their are comments about Mac’s there as well. Note, however, I did not have to resort to dd, drag and drop worked for me. But, if you have problems with drag and drop, dd is definitely to avoid any problems that the software stack used by cp (and other high-level filesystem I/O commands).


#11

@ jeff

Doing the happy dance here. I can use my mac.

This is what works

in a folder that is in the path I created this file

#the contents of /usr/local/bin/savemb.sh

load firmware on mbuino

rm /Volumes/CRP\ DISABLD/*
cp ~/mbuinodl/* /Volumes/CRP\ DISABLD/*
rm ~/mbuinodl/*

I save it as savemb.sh

I put it in /usr/local/bin

I had to use sudo because all the files here are owned by root

#then make it a exceutable shell script
sudo chmod +x /usr/local/bin/savemb.sh

I plug the mbunio into the usb port
hold the mb reset button down 2 seconds
(when you do this the mbuino shows up as /Volumes/CRP\ DISABLED)

I compile and save the firmware file to ~/mbuinodl

I then go to a terminal window and run ./savemb.sh

The unplug the mb and plug it back until the usb and the program runs

This is fantastic. Thanks so much for the hints. I use mac like 99+% of the time and write arduino and LPC1768 code on the mac. This means I can write mbuino code on the mac.

thank you x 1000 times

Eric aka DaddyOh